Jump to content
Sign in to follow this  
ole_1990

Trotz gutem System nur wenig FPS

Recommended Posts

Servus liebe Community 

 

Ich habe ein riesiges Problem mit X Plane 11. Trotz eines wie ich finde guten Systems, habe ich im Schnitt nur 15 FPS. Ich habe schon viel versucht, aber bis jetzt nichts gefunden was mir geholfen hätte😫😫. Auch eine komplette Neuinstallation und alle Grafikeinstellungen auf Minimum setzen bringt komischerweise gar nichts. Die ca. 15 FPS bleiben bestehen.

 

Zu meinem System:

Intel Core I7 4770K 3,5GHZ

Nvidia Ge Force GTX1080 

24 GB RAM DDR3

Windows 10 Pro

 

Vielleicht kann mir hier jemand von euch helfen. Ich bin echt am verzweifeln.

 

Gruß Ole

Share this post


Link to post

Wie gesagt, habe just for fun mal alles auf Minimum gestellt, hat aber nichts gebracht.

Zwischenablage01.thumb.jpg.91bf3354a7eaa742bb99c0c040504c18.jpgZwischenablage04.jpg.04bd7c5658729c6942047c48859640c5.jpg

Share this post


Link to post

Hallo ole,

du musst auch in deinem Nvidia  Systemsteuerung die Einstellungen für X Plane 11 vornehmen. :

 

Nvt1.jpg

 

Gruß Martin.

Share this post


Link to post

Hallo Martin 

Das hatte ich auch schon versucht... vergebens. 

Share this post


Link to post

Hallo Ole,

bei den Einstellungen in X-Plane ist die FPS allerdings verwunderlich. Hast Du mal während X-Plane läuft mittels Task-Manager überprüft, welche Geschwindigkeit die CPU hat (unter "Leistung" unten links - siehe Bild)?

Möglicherweise ist im Bios/Uefi irgend etwas nicht optimal eingestellt.

Gruß Marc

cats.jpg

Share this post


Link to post

@ole_1990

 

Schon mal hier gelesen? Vielleicht hast du ja auch 'ne "Kuddelmuddel - Scenery_packs.ini" ? 🙄

 

 

 

Share this post


Link to post

Moin moin

@tongaluga das mit der Scenery_packs.ini kann eigentlich nicht sein, weil wie oben beschriebenen habe ich XPlane ja komplett neu installiert und noch keine Add ons drin. 

 

@Malthek im BIOS hab ich nichts verstellt. 

 

Gruß Ole 

Share this post


Link to post

Moin, hatte dieses Problem auch, hatte in der Systemsteuerung von Windows auf Energieeinsparung gesetzt.

Auf Höchstleistung gesetzt, danach lief alles wunderbar.

Gruß Willy

Share this post


Link to post

Eventuell nutzt X-Plane auch nur eine Onboard-Grafik und nicht die GTX?

Share this post


Link to post

Doch die GTX wird genutzt, das habe ich schon kontrolliert 😉. Aber es ist eben komisch. Andere Spiele wie zb. GTA 5, FSX, Call of Duty etc. laufen alle weitestgehend flüssig. 

Share this post


Link to post

@ole_1990

 

vor 12 Stunden , ole_1990 sagte:

Moin moin

@tongaluga das mit der Scenery_packs.ini kann eigentlich nicht sein, weil wie oben beschriebenen habe ich XPlane ja komplett neu installiert und noch keine Add ons drin.

 

Moin Ole,

 

na gut, aber es hätte ja trotzdem sein können, dass du vielleicht eine alte Custom Scenery oder Szenierien aus einer alten in deine aktuelle eingefügt hast.

Nachdem das ja aber nicht der Fall scheint, handelt es sich hier schon um ein Problem.

Vorschlag: Poste doch hier mal deine log.txt. Vielleicht gibt sie uns doch Auskunft über ein Problem in deinem X-Plane.

(Alles deutet mir jetzt zwar eher auf ein Konfigurationsproblem in deinem PC-System hin; wogegen aber wieder spricht, dass deine anderen Anwendungen flüssig laufen. 😕)

 

Hoffnungsvoll

Jürgen

 

Share this post


Link to post
On 19.1.2019 at 20:46, ole_1990 sagte:

 

Zwischenablage04.jpg.04bd7c5658729c6942047c48859640c5.jpg

 

 

Die CPU ist das Problem, warum weiß ich aber auch nicht.

 

Die CPU benötigt 0.0719 Sekunden für einen Frame, der Kehrwert davon ist 13.6....

Die GPU benötigt nur 0.0017 Sekunden, würde also für 588 FPS gut sein.

 

Ursachen dafür dürfte es mehr als genug geben.

 

z.B.

- die CPU berechnet Dinge, welche die GPU übernehmen sollte

- Window Scheduler

 

Wieviele FPS werden bei Verwendung der Cessna erreicht?

Wie hoch ist denn die natürliche Auflösung des Bildschirmes?

Wenn du Yokes etc. angeschlossen hast, wie hoch sind die FPS wenn du diese abklemmst?

Wie sieht den die CPU Auslastung / Lastverteilung aus, wenn X-Plane läuft / nicht läuft?

Gibt es verstärkt Zugriffe auf Massenspeicher (Disks etc.) ?

Ist Antivirensoftware aktiv?

 

Wenn man nicht zufällig das Richtige errät, ist in diesem Fall eine Ferndiagnose schwer.

 

Zum Thema (Achtung, ist etwas veraltet, aber es geht um das Prinzip):  https://developer.x-plane.com/2007/04/cpu-or-gpu/

 

/Othello

Share this post


Link to post

Wow ich wusste ja das X Plane sehr komplex ist, aber so.... also kann man sagen die CPU ist der Problemauslöser ?

Share this post


Link to post

Die CPU Zeit pro Frame ist für die schlechten FPS verantwortlich.

Weshalb die CPU so lange braucht, ist noch nicht klar, damit ist die Wurzel des Übels ebenfalls noch nicht bekannt.

 

Du hast ja von mir die Liste an TODOs, klär doch mal ab, wie es sich damit verhält.

 

/Othello

Share this post


Link to post

Jap 👍🏼 Danke werde es die Tage mal ausprobieren.

 

Gruß Ole

Share this post


Link to post

Hallo Flieger,

 

ich habe grade mal meine fps angeschaut.

 

Flugplatz Düsseldorf, Default-Cessna, X-Plane 11.30.

Intel i7 8700K, 16GB RAM, Geforce GTX-STRIX 1070TI, 8GB RAM, Windows 10 (neuste Version)

Ich habe die oben und in einem anderen Thread angegebenen "Tricks"   -> Nvidia-Systemsteuerung, Systemsteuerung usw <-   angewendet und dabei folgende Ergebnisse erzeilt.

 

Die jetzigen Raten sind:

Bei "viele Details": 26-28 pfs, "wenig Details" 28-32 fps.
In der Version 11.25 waren es ähnliche fps, davor hatte ich (soweit erinnerlich) nach Neuinstallation von X-Plane aber teilweise bis und über 50-80 fps.

Jetzt sind dies fps doch deutlich niedriger, obwohl ich in der Grafikeinstellung von X-Plane keine Maximaleinstellungen gewählt habe.

 

24-28-30 fps sind eigentlich, meiner Erfahrung nach, für flüssiges Fliegen ausreichend, wesentlich tiefer sollten sie aber nicht sinken, weils dann anfängt zu ruckeln.

 

Beste Grüße

Wolfgang

 

 

Share this post


Link to post

@ole_1990

Hallo Ole,

ich habe evtl. noch einen Tipp für Dein Problem mit den FPS

installiere dir mal das PlugIn "Rendering.Options.v2.15" 

hier zu downloaden 

https://forums.x-plane.org/index.php?/files/file/38809-advanced-rendering-options-plugin-for-x-plane-11/

unter Menüpunkt "Number of Objekts" den Schalter "Extended DSFS" ausschalten.

Wenn du die Wasser Reflektionen nicht unbedingt benötigst, empfehle ich Dir auch unter

"Water&Reflection" den Schalter "Draw FFT Water (waves)" auszuschalten.

 

Es gibt noch viele weitere Einstellungen, um nicht nur die FPS zu beeinflussen,

sonder auch das gesamte Bild zu verbessern. 

z.B. LOD ratio, u.v.m.

 

Solltest Du das Tool noch gar nicht kennen, empfehle ich Dir unbedingt das Manual zu lesen!

 

Also dann viel Spaß beim Rumtüfteln ;)

 

Gruß

Ludger

 

 

Share this post


Link to post

Hallo Flieger,

ich hatte ja auch   v i e l e   Probleme mit meiner bisherigen X-Plane 30.10-Version und habe sie deshalb auf eine externe Festplatte verschoben und dann X-Plane 11, von DVD, ganz neu installiert, incl. Update auf 30.10.

Fazit: Nach der Installation musste ich erst die Joystick.prf löschen und neu erstellen lassen, danach klappte alles gut. Jetzt sind die Framerates deutlich besser.

Bei „jungfräulicher“   scenery_packs.ini    habe ich fps von zwischen 85- 95 (bei vielen Details) und teilweise bis 105 (wenig Details). In der vorigen Installation waren es nur 24 – 30 fps.

 

Probleme bereiteten die "simHeaven"-Dateien. Als ich die in Custom Scenery kopierte, stürzte X-Plane jedes Mal ab. Nach dem Entfernen lief es dann wieder.
Die danach installierte „hd_global_scenery“ machte keine Probleme, die Framrates gehen damit bei höherer Detailauflösung auf 72 -75 fps zurück. Die Installation hat mich zwar den halben Tag gekostet, 😂🤬, hat sich aber, meiner Meinnuung nach, gelohnt, scon wegen der viel besseren Framrates.

 

 

Ich werde jetzt nach und nach weitere Custom Sceneries installieren und schauen, was passiert.

 

Gruß

Wolfgang

Share this post


Link to post
vor 3 Stunden , wolfmoeck sagte:

Hallo Flieger,

ich hatte ja auch   v i e l e   Probleme mit meiner bisherigen X-Plane 30.10-Version und habe sie deshalb auf eine externe Festplatte verschoben und dann X-Plane 11, von DVD, ganz neu installiert, incl. Update auf 30.10.

Fazit: Nach der Installation musste ich erst die Joystick.prf löschen und neu erstellen lassen, danach klappte alles gut. Jetzt sind die Framerates deutlich besser.

Bei „jungfräulicher“   scenery_packs.ini    habe ich fps von zwischen 85- 95 (bei vielen Details) und teilweise bis 105 (wenig Details). In der vorigen Installation waren es nur 24 – 30 fps.

 

Probleme bereiteten die "simHeaven"-Dateien. Als ich die in Custom Scenery kopierte, stürzte X-Plane jedes Mal ab. Nach dem Entfernen lief es dann wieder.
Die danach installierte „hd_global_scenery“ machte keine Probleme, die Framrates gehen damit bei höherer Detailauflösung auf 72 -75 fps zurück. Die Installation hat mich zwar den halben Tag gekostet, 😂🤬, hat sich aber, meiner Meinnuung nach, gelohnt, scon wegen der viel besseren Framrates.

 

 

Ich werde jetzt nach und nach weitere Custom Sceneries installieren und schauen, was passiert.

  

Gruß

Wolfgang

 

So, ich habe die simHeaven-Dateien einbinden können und X-Plane läuft damit. Framerates bis zu 80 fps.
Schwierigkeiten machen noch die simHeaven_Forest und simHeaven_VFR. Nach Installationsanweisung in Custom Scenery kopiert, stürzt X-Plane damit trotzdem ab.

 

Bin aber im Grund zufrieden.

 

Gruß

Wolfgang

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...