Jump to content
Secondator

[Bug tracking] Missing paper on printer

Recommended Posts

We are currently investigating users reporting some issues with power loss (total blackout), managed speed (IAS drop) and missing paper from printer. We are trying our best to get these sorted as soon as possible. However, these issues are somewhat hard to reproduce and don’t necessarily happen on every system or flight. Therefore, we are now creating topics so that users can give detailed reports that are kept in one place to investigate further and to have some clues how we could reproduce these issues.
 

This thread focuses on issues with missing paper on printer. If you are experiencing other issues or bugs please use the correct thread or if the issue does not fall under the three categories mentioned earlier create a new forum topic under correct category. This way we can manage everything better and make sure that everything gets addressed correctly.
 

If you are experiencing these issues with missing paper on printer, please write a report below with as much information as possible. Even though some information may sound irrelevant, it might still help our testers trying to reproduce the issue

 

Reporting form:

Operating System:
Simulator version:
Airbus version:

System specs:

Description of the issue:

Are you able to reproduce the issue? If so, what are the exact steps you are taking for this issue to happen?

Additional information (route, weights, special area where the issue occurred etc.):

If possible, attach a log file.
We recommend that if you are actively encountering issues with the airbus, you enable logging so that whenever an issue occurs you have the log files ready. If you need help setting up the logging, please see:
https://forum.aerosoft.com/index.php?/topic/142386-how-to-create-logfiles/Also, screenshots or videos (preferably hosted externally on imgur or youtube for example) of the issue happening are greatly appreciated. (Tip: If you have nvidia Shadowplay, you can use keycommand alt+f10 to save the last 5 minutes of gameplay.)

 

 

Other issue tracking threads
Total Blackout: https://forum.aerosoft.com/index.php?/topic/142388-bug-tracking-total-power-loss/

Managed speed (IAS drop): https://forum.aerosoft.com/index.php?/topic/142387-bug-tracking-managed-speed-issues/


All the previous threads on these issues are saved and will be reviewed so no information is lost.
 

Also note that even though we are now mainly focusing on these issues it doesn't mean that other issues are not being worked on actively as well. These are just issues that we find hard to reproduce and need help to track them further. Thanks :)

Share this post


Link to post

After a couple of tests I figured out that the issue with the paper is not to reproduced by any steps taken.

 

I suspect one or more DLL's they are responsible for the print are sometimes not correct loaded or unloaded during the flight.

 

Today I took a flight from LEMH - LIME and all was working fine. After deboarding/reboarding for another flight from LIME - EDDK the printer stops working. (P3D was not restartet.

 

It seems to be the process could not found the PAPER_PRINTSHEET.bpm and the PAPER_WINDOWSHEET.bpm. The 2D of the papersheets are still working after clicking behind the print slot (where the PRINTSHEET should be and clicking at the window site where the WINDOWSHEET should be.

 

Both types are effected from this issue. 318/319 - 320/321

 

Best regards

Artox

Share this post


Link to post

Guys,

as I wrote in that closed topic, as soon as you get this please close the sim and then upload your logfiles: FMGS.log, and MiscD2D.log.

(Make sure you have the "Logging=1" in "FMGS.ini".)

 

Besides, those who still experience this issue, do you all have the V4.4? And do you all have it when printing weather, not other reports?

 

I still can't reproduce, and still have no logfiles from you. Anyway, I made few changes that could fix the problem.

Please retry with a next update! In case of the problem persists, please upload the logs and answer those questions.

Thanks.

Share this post


Link to post

Hi,

I had my first invisible paper problem in the printer followed by a CTD when I clicked on the "invisible" paper on the pilot window...
Config in my signature
A320 Niki
V1.2.3.2

P3Dv4.4

No logs (they were not enabled) except MiscD2D.log

Thanks and Regards,

Richard

MiscD2D.log

Share this post


Link to post

Shut down at the gate, I hear the printer churning.  I look down and there's no paper.  I click on the printer and it moves the invisible paper over to the chart clip (it remains invisible).  I click on it there and it's the flight log.

 

A319 IAE.  1.2.3.2 (just updated last night).  Windows 7 pro.  i7-4790k @ 4.5ghz.  GTX1080ti.  32GB DDR3.  P3D V4.4

 

Logs attached.

printer issue log.zip

Share this post


Link to post

I also have this issue from time to time. It's not reproducible. On 3 of 4 flights everything works finde but, then, all papers don't show up through the entire flight.

Unfortunately I only found this thread after the issues occurred so there is no log. But I'll help with all the other information:

 

Windows 10 Home

P3D 4.4.16.27077

Airbus 1.2.3.0

Lufthansa A320 D-AIZQ (CFM, sharklets)

 

System specs:

i5 9600K @4.8 Ghz

16GB DDR4 RAM 3000Mhz

MSI GXT 1080ti

 

Route: LOWW-EDDF, LUGEM DCT SUBEN T161 PSA

weights: 5.8t fuel, 1.9t cargo, 151 passengers

No special area, as it happens throughout the flight

 

After clicking on the printer, my sim crashes. The printer makes the normal sounds, but there is no paper being printed.

 

@Secondator Is there anything new regarding this issue? The thread is open since January.

 

p3d.thumb.PNG.0a43d2f5df7a27b99bef3e74ed366297.PNG

Share this post


Link to post

Hello Meyerflyer,

Unfortunately, there isn't any news regarding this issue. We have done some changes on printer on the last few experimental updates, so maybe you could try to update to 1.2.3.2 and see if you can still reproduce the issue then. It's very hard bug to track since we don't get many reports on it and the beta testers cannot reproduce it. But we'll keep alert if we manage to recreate it and see what it's all about.
 

Thanks for the report anyways!

Share this post


Link to post

I just had this problem. A320 CFM, version 1.2.3.2

2019-3-26_14-51-9-781.thumb.jpg.92e7f6da3097e6eab335d025e657b041.jpg2019-3-26_14-51-22-536.thumb.jpg.52c1fa87e25415abeae23350993b01a8.jpg

Share this post


Link to post

Damn, you know we have literally no idea what could be causing this? 

Share this post


Link to post

Maybe it would help to build a special printer log to track down all printer activities and its status?

 

One time, where I didn't know that the sim crashes when clicking on the printer, I made this click on approach after a 2h flight and ended up on the desktop shortly before landing. That's the worst thing that can happen when flying sim. 😞

Share this post


Link to post

EDIT : I have the same problem as Meyerflyer, but it was my first time since I own the Airbus.

 

I had another strange problem, just few minutes ago. When the load sheet was supposed to be printed, I heard the printer sound but there was no paper. I thought that the paper was invisible, but i could not click on it (usually that works). Then I tried to print again by pressing the AIDS Print button. I had the sound again, but still no paper. And when i clicked on the printer, my game crashed 😕

 

A320CFM, version 1.2.3.2

OS : Windows 10 Pro, Addons : Orbx, Active sky, Aerosoft EDDB, Rex Sky Force

 

The program Prepar3D.exe version 4.4.16.27077 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: f70
 Start Time: 01d4e7b1142cf0b5
 Termination Time: 51
 Application Path: T:\Prepar3D v4\Prepar3D.exe
 Report Id: 461c2014-5d23-4254-93f1-e5c85dda036e
 Faulting package full name:
 Faulting package-relative application ID:

 

Share this post


Link to post

hi guys,

I still have no clue on the reason what causes this problem, and the logs contain nothing remarkable.

Nobody knows how to recreate the issue?

Okay, I'd appreciate if you at least give me the Windows error report after the CTD, like in the example below:

 

Exception code: 0xc0000005
Fault offset: 0x016c870f
Faulting process id: 0x111c
Faulting module path: MiscD2D.dll

.

 

Share this post


Link to post

Hello everyone

 

I wanted to make a small bug report on the printer just now during the flight I ask the metar via AOC I press print I hear the sound of the sheet but no paper ...

It's extremely rare so I just know I do not have to press or should it find the sheet otherwise P3D crash.

 

No event in the windows watcher ...

 

Have a good day

Share this post


Link to post

Hello Everyone,

Windows 10 Pro 64bit

P3DV4.5

Airbus (both series) 1.2.4.0

Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz (12 CPUs), ~3.7GHz

Memory: 16384MB RAM

GeForce GTX 1080 Ti

same problem here both with the 319 and the 321.

The printers made the sound, but no paper displayed. If i click on the printer P3DV4.5 Crahsed (like the errors reported in this page).

In some times all works properly, in others not (and when it isn't it's a CTD). With the previous versions no issues at all with this point.

 

Hope you can find soon the right way to handle and resolve it

 

Regards


 

Share this post


Link to post

We have made some changes and will share those very soon. The main problem remains that we are unable to recreate this on any of our systems. 

 

1.2.4.1 Experimental
    Bug Fix: Issue with doors states fixed
    Bug Fix: Incorrect deletion of the DISCON after selecting an approach
    Bug Fix: inHG Altimeter dot added
    Bug Fix: Issues with multiple VORs with same code fixed
    Bug Fix: Prevention of giganormous logfiles
    
    
    Improvement: Finishing GSX2 interaction
    Improvement: Demo of VC objects removed
    Improvement: Possible fix for printer issues
    Improvement: Some tweaks to PFD
 

Share this post


Link to post

A little update on the CTD Question.

Today I've performed a flight from EFHK to LSGG. 

All run smooth, since i didn't print any weather Metar due to the issue described in this topic.

Once on ground on stand with APU connected I've switched off the engines and this happened:

- Printer made the sound since i was expecting the paper with all flight data

- Suddenly Driver of my VideoCard crashed saying if i want to continue/end p3d/or try to reload it (P3D crashed immediately after that).

 

Never occurred in every version before this one (also the graphical card driver never crashed in every situation, even with sceneries, airplanes from aerosoft and/or other Dev.)

 

Cheers

Share this post


Link to post

a little updated with 1.2.4.1 

Performed 4 flights EFHK-EFTU-EFHK and EFHK-ESKN-EFHK with the printers and i've not encountered any issue at all. Seems work perfectly as before! Thanks Aerosoft

Share this post


Link to post

Hi! With version 1.2.4.1 i thought that the problem was solved, but after i install version 1.2.4.2 the problem still occurs. Best wishes.

Share this post


Link to post

Hello brtkstn,

 

So you don’t have any paper coming from the printer but hear the printer sound? Could you please enable logging, try to recreate the issue again and zip the Data folder in whole and send it here. It would much help us to have a better look into this issue.

Share this post


Link to post

Hello, yes i will enable logging and try to recreate this issue which will be difficult, because i see it only from time to time. Maybe i'm wrong, but i have a hint. I think that the issue is present only when i start P3D and A320 PRO first time after system restart. When i start them second time and so on, the problem does not exist. But again this is just my suspicion. Regards.

Share this post


Link to post

The issue with no paper is still continuing. Any idea how to solve it?

 

Share this post


Link to post

We have not seen this issue for some time. Are you sure you are at the latest build?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...