gsaldes

P3D Crash when loading a320 P3d v4.3

Recommended Posts

Hi guys,
first of all I apologize for my english, I do what I can.

I downloaded yesterday the Aerosoft A320 / A321 Professional software from Just Flight, I installed it and I get the bad surprise that when selecting the plane (with any livery), after loading, P3D crash.
It doesn't allow me to do anything, it just crash down.
Checking this forum, I have uninstalled RAAS, AI traffic, GSX, REX, etc. and nothing goes better, just is not able to support it and freezes the simulator.

 

It's weird but, I can load the same plane but the version for FSX that we already know works half in p3d.

My machine it's equipped with win10 64bit, 16gb ram, two graphic cards (1050 and 1070) and intel i7, so, I don't think my problem is hardware.
In my simulator I have complex airplanes of PMDG and Carenado that works perfectly, the problem is only given to me by Aerosoft.

I'm not a systems expert, so I ask you to give me some simple solution.

Thank you very much for your time, regards!

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

First of all a detailed error message would be helpfull. Check the Windows Eventviewer in case you dont get an error message at the time of the crash.

Then you should update the Airbus to its latest version via the ASUpdater.

Share this post


Link to post
Share on other sites

Hi mopperle,

 

this is what eventdata says:

 

Prepar3D.exe

      4.3.29.25520
      5b2c3263
      nvwgf2umx.dll
      23.21.13.9065
      5a4d6d2a
      c0000005
      000000000021bd0a
      2130
      01d4a05524f7371a
      E:\PREPAR3D\Prepar3D.exe
      C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_5601d21ccd639df9\nvwgf2umx.dll
      0818b37c-7017-42b1-bd9d-5abf83973212
       

 

 

     

Share this post


Link to post
Share on other sites

Thanks, but what they say in that forum didn't help me solve the problem.
I don't have this problem with any other software or airplane in the simulator, only with the aerosoft A320/A321 professional.

Share this post


Link to post
Share on other sites

Did you also check all the other very recent topics regarding this error?

Currently you are the first one with this error.

On which version of the Airbus are you?

Share this post


Link to post
Share on other sites

Yes, I´ve already reviewed all the topics and nothing.
I guess I'm in the latest version cause I updated it with AS Updater and downloaded it yesterday and I have tested in different models of 320 and 321. I´ve reinstalled it several times and nothing changes.

 

Share this post


Link to post
Share on other sites
3 hours ago, gsaldes said:

Yes, I´ve already reviewed all the topics and nothing.
I guess I'm in the latest version cause I updated it with AS Updater and downloaded it yesterday and I have tested in different models of 320 and 321. I´ve reinstalled it several times and nothing changes.

 

 

To be sure, just take a look at the version number shown in the Updater and let us know what it is. Here, the requested information for the Airbus is version 1.2.2.1. v1.2.2.0 is for the updater and is not what Otto asked about. Note also that experimental updates is activated.

 

Untitled.jpg

 

Share this post


Link to post
Share on other sites

Hi Herman,

 

it's just like as you show it but a difference on Add-on Path:

 

"Regular as well as experimental updates are available for installation


Prepar3D 4.x found: (E:\PREPAR3D\)
Flight Simulator X Steam found: (C:\Program Files (x86)\Steam\steamapps\common\FSX\)

Product Name: Aerosoft A320-A321 Professional for Prepar3D v4.x

Add-on Path: E:\PREPAR3D\aerosoft\Aerosoft A320-A321 Professional


Installed version: 1.2.2.1
No updates available for this product!"
 

 

Share this post


Link to post
Share on other sites
46 minutes ago, gsaldes said:

Hi Herman,

 

it's just like as you show it but a difference on Add-on Path:

[Deleted portions to save room]

46 minutes ago, gsaldes said:


Installed version: 1.2.2.1
No updates available for this product

That’s what we needed to know. So one more thing eliminated.

Share this post


Link to post
Share on other sites

There was an issues, if using Carenado models. 

 

"What I'm wondering is this....

 

For everyone who is having this issue, please report if you're using AI Traffic (whether generated by P3D, VATSIM, IVAO or by other means.  Also, please report if you have or don't have any Carenado aircraft installed.  Their is a DRM problem with Carenado software that will kill the engines of non-Carendo aircraft if the model is called by an AI aircraft.

 

For those interested in helping rule this out.... please do the same flights without any AI/Online traffic and see if you still see the problem."

 

Don't know what is situation today?

 

 

 

Share this post


Link to post
Share on other sites

I had a similar issue recently, which turned out to be an incompatibility between the reallight and trueglass installed by the Airbus and another add-on airplane.

 

As a test, try renaming the reallight.dll and trueglass.dll files (in your P3D\gauges directory) to .old (or something other than .dll) so they won't be loaded, and see if that makes a difference.

Share this post


Link to post
Share on other sites
10 hours ago, gsaldes said:

Prepar3D 4.x found: (E:\PREPAR3D\)
 

Product Name: Aerosoft A320-A321 Professional for Prepar3D v4.x

Add-on Path: E:\PREPAR3D\aerosoft\Aerosoft A320-A321 Professional

Another try might be to install the airbus outside the sim root folder.

 

Share this post


Link to post
Share on other sites
19 hours ago, gsaldes said:

two graphic cards (1050 and 1070)

Which is used by P3D, or are you running SLI? If so set the SLI rendering mode to single CPU.

Share this post


Link to post
Share on other sites
11 hours ago, aviator64 said:

I had a similar issue recently, which turned out to be an incompatibility between the reallight and trueglass installed by the Airbus and another add-on airplane.

 

As a test, try renaming the reallight.dll and trueglass.dll files (in your P3D\gauges directory) to .old (or something other than .dll) so they won't be loaded, and see if that makes a difference.

 

Guys, we have a winner! Aviator64, thank u very much!
problem solved, I did what you mention and it works perfectly,

and thanks to everyone who helped me !!

 

happy flights, see you in the air

Share this post


Link to post
Share on other sites
21 minutes ago, gsaldes said:

 

Guys, we have a winner! Aviator64, thank u very much!
problem solved, I did what you mention and it works perfectly,

and thanks to everyone who helped me !!

 

happy flights, see you in the air

So are you now flying without reallight and trueglass?

Share this post


Link to post
Share on other sites
27 minutes ago, masterhawk said:

So are you now flying without reallight and trueglass?

🙄 not yet, I'm not flying, now I'm trying to set the view of the cabin

Share this post


Link to post
Share on other sites

Well, with those renamed files you will fly without reallight and trueglass. So no lighting in the cockpit and no rain effects. 

Share this post


Link to post
Share on other sites
3 hours ago, Tom A320 said:

Well, with those renamed files you will fly without reallight and trueglass. So no lighting in the cockpit and no rain effects. 

That´s not so good, the plane is flying without problems (so far), I think I´m gonna use it like now for a while.

Share this post


Link to post
Share on other sites

I can confirm the same, if I remove trueglass and realight dll from the sim, the Airbus works again. This problem appeared only after I updated the TFDi 717 btw.

Share this post


Link to post
Share on other sites

Well, as an update, after removing the trueglass and reallight dll's from the gauge folder and going through the TFDi folder, it looks like a new version of both gauges were created a day or so later. My Airbus works again :)

Share this post


Link to post
Share on other sites

Thanks for the update. I leave thi stopic open for te moment, So that mabe the other guyes can tell whether they are also using the TFD 717.

@dandan87: May I ask you what kind of graphiccard you are using?

Share this post


Link to post
Share on other sites

The crash is for sure not related to cards to drivers as these tools do not talk to hardware on a low level. I would far more expect runtimes etc to be problematic.

Share this post


Link to post
Share on other sites

Hi,

 

As I also had problems with RealLight (multiple graphic cards and P3D 4.4 lead to CTDs), I tried the hint of dandan87 and removed the DLLs. Then I ran the supplied installers for RealLight and TrueGlass again and got the new versions of the DLLs (date 12/25/2018). With these DLLs I am able to start and stop the bus without CTD.

 

But as soon as I am turning on the OVHD integral light, the light goes on shortly and then with a CTD the sim stops again.

 

So the new version is a little bit better but the (known problem) with two graphic cards and RealLight in P3D is still not fixed finally. SoRealLight is still enabled in my bus.

 

Rgds
Reinhard

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.