New releases: Geneva professional and OnAir: Airline Manager

Jump to content
samwise7

Ecam flight control page

Recommended Posts

I noticed today on my first try with the IAE A-320 latest build 1.2.1.5, during the flight control check at full aileron deflection, only the outermost surfaces displayed green arrows. Until this build if you moved the control stick all surfaces on that side of the wing would stand up (including the spoilers) and the green arrows would all be displayed on the ecam. 

 

Everything seemed to work well, and even this had no adverse effect on the flight at all, but I'm wondering if I need to re-install the update, or if this is correct and by design?   

Share this post


Link to post

We have not touched that bit of code for years.  Almost certainly that indicates your controller does not have full travel. I suggest to recalibrate it.

 

image.png

Share this post


Link to post
24 minutes ago, samwise7 said:

I'll try your suggestion. Thank you Mr. Kok

 

By the way... love the username you selected!  Very cool!

 

  • Upvote 1

Share this post


Link to post

Warthog HOTAS calibrated in both Windows and P3D:

image.thumb.png.4c74eec0a8ed29917116690d40d0f1e5.png

Full left deflection and ECAM shows:
image.thumb.png.3c703b4831aba4a6b57e08f9465caa8c.png

Default Delta A321, Aerobus version 1.2.1.5.

Share this post


Link to post

I got the sam.e I think there's a problem here. No change in stick setting. Was working normal. Now it shows only the outermost arrow.

 

A320 CFM

Share this post


Link to post
7 hours ago, Mathijs Kok said:

Almost certainly that indicates your controller does not have full travel. I suggest to recalibrate it.

Same results after re-calibration sir, on both IAE and CFM models, as soon as the AC is airborne full ECAM indications return. 

Not an earth shattering issue by any means. 

Share this post


Link to post

Well, it is problematic for sure it indicates that the aircraft does not read the full scale of the joystick movement. The image also shows the small cross not fully right so that should match. Can you show the calibration screen?

Share this post


Link to post
4 hours ago, mopperle said:

Bug confirmed and will be solved.

Fantastic!, I'm sure you and your team will have it working in no time. Just one other thing I noticed, the caution for TCAS when inactive shows twice, once in amber and once in green.

Thanks, 

Jose 

Share this post


Link to post
20 hours ago, Mathijs Kok said:

Well, it is problematic for sure it indicates that the aircraft does not read the full scale of the joystick movement. The image also shows the small cross not fully right so that should match. Can you show the calibration screen?

 

Late reply, the bug has been found..

 

The cross on the Windows screen won't go all the way to the side by design. I guess I forgot to take a screenshot of the P3D Controller Calibration screen where it shows full values for X and Y from 0 to 16384 (14 bit sensor).

Share this post


Link to post

Mmmm on my calibration screen the crosse touches the sides. But as said we found a possible cause.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...