Aerosoft official retail partner for Microsoft Flight Simulator !! 
Click here for more information

Jump to content
viperstorm21

Flickering Screen

Recommended Posts

Hello Everyone! 

 

So I've been having this problem for a while now and I'm finally coming to the forums for help after pulling my hair out lol. When I use the Aerosoft Airbus A318/19 Professional, my screen flickers to the point that it's unflyable (video posted below). When I start the flight the problem seems to be fine but the longer the sim runs, the worse it gets. I've tried changing my graphics driver and installing the aircraft into a vanilla sim to see if the problem would be resolved but no luck :mecry_s: I don't know if this could have anything to do with it but I run my flight sim on separate SSD than windows. If you need any other information from me please let me know :)

 

PC Specs (Just in case if you need them).

CPU: i7 4790k

GPU: GTX 980

Ram: 16gb

 

Share this post


Link to post
Share on other sites

Which version of P3D are you using? Also I see some strange greenish colouring. Any shader tweaks or any other tweaks?

Share this post


Link to post
Share on other sites

I'm currently running version 4.3.29. I am running a shader, to be specific, it's R&Dv1.5 (tomatoshade) installed via PTA. When it comes to other tweaks, I don't have any installed. 

Share this post


Link to post
Share on other sites

OK, I move it to the correct forum. Turn off all shader tweaks. It is known that they cause more and more problems.

Share this post


Link to post
Share on other sites

Same problem after the latest update. If i changed the view to outside no problems. It is only in the cockpit.
Regards

Jo va Bra

Share this post


Link to post
Share on other sites

Hi all, I have the same Problem. But it is not related to Airbus, is happening also in default or PMDG. For me the problem started direct after install of Win10 1809. I also tried all. At some point I will try a fresh setup incl. Win10 and then test with vanilla P3D. I'm usind default shaders.

Share this post


Link to post
Share on other sites

Reducing my framerates help tremendously! Thank You! :D I'm curious, will Microsoft put out a fix for this and if so how long would you guess for it to take? 

Share this post


Link to post
Share on other sites

I noticed this problem the moment I went to update 1809 (which windows pulled after the issues) - I went back to prior to 1809 and problem resolved itself completely. 

Share this post


Link to post
Share on other sites

I'm getting the same flickering when using Aerosoft A320 Professional with P3D v4.4. I have many other aircrafts (e.g. iFly 737/747, Carenado Phenom 100, Flight1 B200 King Air, A2A Cessna 172, Just Flight DHC3 Otter, etc), and none of them present this issue.

 

Video:

https://drive.google.com/file/d/1pZ70-3qvIYxCu52GQkKGliw8TB9Nf4Oc/view?usp=sharing

 

Right now the aircraft is unusable for me, because of this issue.

 

I could not find the FPS limiter in P3D - are you using the limiter of the video card software?

 

Is there any solution to this problem? Limiting the FPS does not seem to me a good solution, as I don't have the problem with other aircrafts.

 

 

Share this post


Link to post
Share on other sites

image.thumb.png.9a15e9919b074631fdee3dae8bae7d1f.pngHave you ticked Disable full Screen optimisations via the P3D.exe? if not give it a go

Share this post


Link to post
Share on other sites

In my case an updated driver for the graphiccard solved the problem. BTW. not only an Airbus issue got the same with some default aircraft.

Share this post


Link to post
Share on other sites

Disabling "full screen optimizations" fixed the flickering for me and many others completely.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...