Jump to content
Horst K

X-Plane 11 friert ein

Recommended Posts

Ich habe aktuell das Problem, dass X-Plane 11.25 immer mal wieder einfriert. Ich fliege dabei ILS Anflüge auf LOWI 26. Zur Analyse läuft parallel  die AI 3 Suite von ASUS und der Ressourcenmonitor. Schon beim Laden des Programms wird gezeigt, dass von X-Plane ca. 10-15 sek. keine Rückmeldung kommt, danach wird das Programm weiter geladen. Das gleiche passiert dann gelegentlich bei guten 25 - 30 fps. Die Temperatur der CPU liegt bei ca. 42 Grad C. Die CPU ist auf höchste Leistung gestellt und taktet mit 3,871 MHz.

OS Windows 10, 1803 mit aktuellen Patches, CPU i7-6800K, GPU NVDIA GTX 1070 Ti, RAM 32 GByte, SSD Samsung EVO 970 Pro.

Im Anflug ist die CPU mit ca. 25%, die GPU mit ca. 35 % und der RAM mit 25% ausgelastet. Urplötzlich stoppt das Programm und liefert lt. Res. Monitor keine Rückmeldung mehr, Auch hier wird nach ca. 10 - 15 sek. alles wieder normal und ich kann den Anflug beenden. Die AI 3 Suite und der Res. Monitor liefern weiterhin aktiv Daten.

Ich habe schon alle Grafik-Einstellungen von X-Plane geändert, dies bringt keinen Erfolg. Auch die Add-On´s habe ich schon mal vollständig entfernt. Auch dies zeigte keinen Effekt.

Im X-Plane Q&A Forum konnte mir bisher niemand helfen.

Ich hoffe einer von Euch hat einen Tip.

 

 

Share this post


Link to post
Share on other sites

"Keine Rückmeldung" wird immer dann prognostiziert, wenn das Programm auf Anforderungen nicht in einem gegebenen Zeitrahmen reagiert.

Das dürfte immer dann der Fall sein, wenn das Programm "hängt".

 

Eine andere Ursache ist dann gegeben, wenn der Hauptthread selbst am Programmablauf mitwerkelt und dadurch nicht auf Ereignisse (z.B. Maus Ereignisse) reagieren kann. Dies ist meiner Meinung nach in X-Plane der Fall.

Eine Lösung wäre dann, dass der Hauptthread für die anstehende Arbeit (Daten laden ...) einen Hilfsthread startet. Dadurch bleibt das Fenster ansprechbar, die eigentliche Arbeit (z.B. Daten zu beschaffen) ginge damit aber auch nicht schneller.

Gewonnen wäre dadurch nur, dass die Meldung "Keine Rückmeldung" nicht mehr erscheint.

 

Wirkliche Abhilfe wird wohl erst dann geschaffen, wenn X-Plane besser parallel arbeitet.

Zur Zeit würden mehr Kerne nur zu einer geringeren Auslastung führen.

 

Als Beleg möchte ich anmerken.

 

Auch auf meinen System sehe ich beim Start und zwischendurch beim Nachladen von Daten die von dir geschilderten Anzeichen.

An zu geringer Systemleistung kann das allerdings nicht liegen, denn ich habe versehentlich X-Plane zwei mal gleichzeitig auf meinem System gestartet (in Desktop1 und Desktop2). Beide Instanzen liefen mit einer ca 2-3 Frames/s geringeren Leistung als eine Instanz alleine!

 

 

Und das ganze als kurze Antwort:  Nein, der Betrieb steht nicht, die Empfangsdame hilft nur eben im Lager aus   :-)

 

 

Gruß

Othello

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hallo Othello,

ja das stimmt wohl, denn sobald das Freezing nach den benannten 10 - 15 Sek. verschwindet. kann ich ja weiterfliegen.

 

Ich glaube, dass ich heute Nachmittag das Problem gefunden oder zu mindestens eingekreist habe.

Ich hatte beobachtet, dass immer in dem Moment des Freezing ein Windows Sound (USB disconnect / connecting) auftrat.

Daraufhin habe ich erstmal alle nicht benötigten Geräte abgekoppelt und dann begonnen, im Gerätemanager von unten beginnend die Geräte zu entfernen. Nachdem ich den USB Hub der Tastatur / Maus erwischt hatte :fallingbricks_s:, konnte ich logischerweise nichts mehr entfernen :crylaugh_s:. Nach hartem Kaltstart war soweit wieder alles ok.

Ich habe dann X-Plane gestartet und erstaunlicherweise konnte ich während des aktiven Fluges kein Freezing mehr beobachten. Nach drei Anflügen, ist statistisch und wissenschaftlich natürlich noch keine belastbare Testreihe, ist immer noch alles ok.

Erst war ich erstaunt, aber nach Deinen Hinweisen war anscheinend temporär eine USB-Kommunikation (Joy Stick ?) durch einen Fehler (Treiber etc.) abgerissen und diese blockierte anscheinend X-Plane für den genannten Zeitraum.

 

Ich habe das im X-Plane Q&A auch so weitergegeben.

 

Übrigens kann ich bestätigen, dass beim Laden X-Plane mehrfach keine Rückmeldung liefert. Das kann man im Ressourcenmonitor gut beobachten.

 

Hallo Heinz,

danke für das Verschieben ins deutsche Forum.

 

Viele Grüße,

 

Horst

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...