New releases: Geneva professional and OnAir: Airline Manager

Jump to content
Sign in to follow this  
Goofey007

Nightmare after installing Bronco X

Recommended Posts

Hi,

 

I took today advantage of the 20% off promotion on the military aircraft sale.

And bought Bronco X, EE Lightning F3 X and Huey X.

Buying, downloading from the DL shop is straight forward as always.

I am posting under Bronco because it is the first plane I installed.

 

I am using mainly FSX, and usually install only for FSX.

AV disabled and run the installer as administrator.

And, exeptional, today  I ran the installer a second time for FSX-SE and a third time for P3Dv3.

So far no problems encountered.

To my surprise the installer of EE Lightning F3 and Huey X did not find the FSX folder anymore. Pointing the installer manually to the fsx folder also did not help.

Just to check what is going on, I launched Simstarter NG. Normally I have to choose the fsim. This time there were no choices presented

 

This is what I found after the installation of Bronco X:

-All files under the main folder of FSX, FSX-SE and LM P3D are gone !

-The subfolders are still there

-The bronco installer created folders in the respective simobjekts subfolders. So I assume the plane is installed

 

At this moment I am assuming a corrupt download caused this nightmare.

I used the 'Mirror EU' button in my download account.

Firefox is my main browser, no download addons. Unzipping of the download is done in windows explorer and did not cause any problems.

 

Is it possible to post a hash (MD5/SHA/...) for the downloaded file (AS_BRONCO-X_FSX-P3D-FSXSTEAM.zip) so I can check?

 

I am assuming that my windows register is not affected

 

Johan

 

 

 

 

 

 

 

 

Share this post


Link to post

Here is a small update.

 

Starting FSX-SE under Steam triggered a redownload of the missing files. (±11Mb) After downloading these files, FSX-SE is up and running. The Bronco is there :D

For fixing LM I uninstalled P3Dv3 completely. Leftovers  were folders/files of the bronco  installer. I did not  manually delete them. I  reinstalled LM to the exact same  location/folder.  P3D is up and running again  and yes..the Bronco is there :D

 

I can now again choose a flightsim at startup of Simstarter NG

 

To do: reinstall FSX... Yes , I know ...get rid of it  :rolleyes:

Share this post


Link to post

The installer checks it's own content before the installation starts so you can be 100% sure it is correct when the installer starts.

I have no explanation for your problems. The installer does not contain a single delete, rename or cut command and the same installer did not cause such issues with all other customers.

 

I understand this does not really help you, but I do state the installer might have triggered something, but it did not delete any files.

Share this post


Link to post

 

Thank you  Sir  for  your  input.

I concur  with  your  statement  that  there  is  a  anomality  on  my PC,  that causes  this and  is triggered  by  the  Bronco  installer.

After restoring  FSX-SE  and  P3Dv3  yesterday I could  install EE  lightning  F3  (to FSX-SE  &  P3Dv3)  and Huey  X (to  LM) without  problems.

Today  I  run  the Bronco  installer  a  second  time.  And  guess  what?

The installer  did  it  again. Because  FSX  is not  restored  yet, I choose  to  install  the bronco to  FSX-SE .

Again  all  the  files  in  the root  directory  of  the  flightsim  are  gone.  This  means  the anomality  is still  there.

 

Sir, I  realize this is hardly  your problem,  and  want  to  apologize for the somewhat harsh  heading on  this  topic

I  do  hope  that  someone  comes  up  with  a proposition  on  how  to  takle this.

 

Thank  in  advance  for reading  this

 

Johan

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post

No problem, I would be highly interested in knowing what caused this. It is seriously weird.

Share this post


Link to post

At  the moment  I am  grounded  ;)

So  there  is  time  to  investigate

If  I  can  pinpoint this ,  I'll  post  it  here

 

Johan

 

 

 

Share this post


Link to post

Here  is  a  small update.

Today  I  spent  some  time  uninstalling  every  flightsim addon (Scenery/aircraft/tools) and  almost all programs  not  related to flightsimulation.

I did  run a registry  cleaner  and  made a clean  install of MS  FSX.

I  ran the bronco installer  and again  it triggered the disappearing of all  files in the root-folder of FSX.

I took some screenshots  of every fase of  the installer  with windows explorer  showing the  files of FSX installation  folder.

As you can see at the end  of installation the bronco is installed.

The  files  disappear during the copy process when  the progress  indicator  is ±halfway.

 

I  restored the files from the flightsim folder,  started  FSX  and  all seems to be working okay  , incl  bronco.  (=Work  around :D)

Ran the installer  with UAC turned  off,  same result

And  just  to check ,  I ran  the installer on another PC  (Other hardware components).  The anomality  there  also exists. 

The two PC's have one common factor.  They are both  on Win10 Pro V1709 B16299.248

And again,  only this installer triggers the anomality.  All other  addons install normally.

 

I am  not a  software engineer  and running out of options here.

I do  have a spare drive, so I'll  install Win7  and try  it again. 

 

It is odd that only this installer  triggers  the anomality.  There must  be  a difference  with other addon installers

MD5  checksum of  AS_BRONCO-X_FSX-P3D-FSXSTEAM V1.12.zip  =  1f6e8a56cf768d7c157c456eb87488cf

 

Just guessing

 

 

 

 

 

Before starting installer.JPG

After  starting  installer 1st  screen.JPG

After  starting  installer 2nd  screen.JPG

So far  so good.JPG

So far so good  2.JPG

So far so good  3.JPG

So far so good  4.JPG

All  files  gone in the root  directory of the sim.JPG

Share this post


Link to post

Can you confirm you are using this one?

 

AS_BRONCO-X_FSX-P3D-FSXSTEAM.zip =>

·         AS_BRONCO-X-FSX_P3D_FSXSTEAM_V121.exe             283.521.944        18.08.2017 09:00              -a--

·         Licence agreement Aerosoft DE.txt       5.764     18.08.2017 09:00              -a--

·         Licence agreement Aerosoft EN.txt       3.741     18.08.2017 09:00              -a--

·         Licence agreement Aerosoft FR.txt       2.978     18.08.2017 09:00              -a--

·         Licence agreement Aerosoft SP.txt       3.337     18.08.2017 09:00              -a--

Share this post


Link to post

Okay....  we tried this on a few machines but simply are unable to get the same results. For now it's a very strange issue.

Share this post


Link to post

You  have  not  by  any chance  implemented  a  new kind of DRM  technology?

STEALTH  technology:D better than the  other company  :rolleyes:

 

Sorry,  could not resist.

Most certainly NO offence  meant. I  know  you  are  all working  very  hard  and even  looking into this  issue. (Probaly  a  one   in a million)

I also  must admit  that,  allthough I  am  eager  to   get  airborne  again  and leave  this behind  me, I  am  intrigued.

I found  the  spare harddrive  here, I  do have  another copy  of  Win7. 

I will make a  clean OS  install  +  FSX  and run  your  installer.  It  will be with a 3rd combination of hardware

I have not  decided yet  for a new win 10 installation on the main gaming PC.

 

Keep up the good work and THANK YOU everybody

 

 

Share this post


Link to post

This is  weird.

Just finished installing Win7Pro  sp1 , fsx  Deluxe Edition on a  clean hdd  (created  2  partitions). Nothing else  installed

Hell, I  did not  even install graphics  driver  and  motherboard  drivers.  (No  network  connectivity)

 

Just  copied  the  bronco  installer through  a  USB  stick  to  this  3rd machine.

And  again  all  files  under  de  root folder of the flightsim disappear during copy process  of  installer.

 

This brings me back  to  the  beginning  of my post.  The installer must  be compromised in one  way  or  another

 

 

 

Share this post


Link to post

Just downloaded the  bronco installer  from my DL-account  again. (Mirror EU)

Everything is okay now. No problems anymore. No deletion of  files

I notice that the file has been changed and the  creation date is rather recent;)

 

For  your  information:  the file downloaded  through Mirror  World is still the old one  ( AS_BRONCO-X-FSX_P3D_FSXSTEAM_V121.exe             283.521.944        18.08.2017 09:00 )

 

I am very curious now as what did happen?

 

 

new  installer.JPG

Share this post


Link to post

I have no idea. I checked the files to see if they were okay and they were.  Just glad to see it solved!

Share this post


Link to post

Sir,

 

with  respect. That is not good  enough explenation  for  me.

I  do have  here  2  versions  of  your installer.

One  deletes all files  under  the flightsim  folder,  the second  (283  521 688b  created  28  feb  2018)  is  oke

Share this post


Link to post

Do I  have  to  be  worried  now,  each  time  i  run   an installer  that  my  flightsim  files will be deleted?

Clearly , downloading, unzipping  and running successfully an installer  is no  indication  that  there CAN go  something  wrong?

Share this post


Link to post

Just  downloaded  the  bronco  installer again , using  the  Mirror World  option.

The file  is  now also  the  latest version (283  521 688b  created  28  feb  2018)

Aerosoft, you must  be  doing something?

Share this post


Link to post

I would not worry about files being wiped as we simply have not seen this with other customers.  We have indeed updated the installer with a function that simply prevents it from touching other files. 

Share this post


Link to post

It is hard  not to worry. I do know now that  it is possible.

Especially my last  attempt  with clean installation of OS and no drivers installed,  makes me confident I can showcase  this  file  wiping on  every combination of hardware,  any place any  time...

So everyone is hereby invited for a demo :rolleyes:

 

Sir,

Appreciate  the effort (adding  a function that simply prevents touching other files). Thank you and your team

 

However  ,  this  file  wiping thing is far  too intriguing to  let  go

 

Johan

 

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...