Jump to content

Archived

This topic is now archived and is closed to further replies.

PeterZ KCLE EDDN

Performance drop w/1.0.1

Recommended Posts

Gents,

 

First, please let me preface that I am running an ancient 5 year old PC. It is a clean and FS only PC and with responsible settings (pretty much medium FSX settings) and textures no higher than 1024 I have been fortunate to be able to run all complex aircraft add-ons locked at 30 fps rather smoothly (with NVDIA's vsync half refresh rate of monitor).

 

I feel as if the last update (1.0.1) has decreased performance on my PC noticeably. While I don't look that much at the FPS counter, I usually do so when somethings seems off. With this new build I'm seeing fluctuations in FPS from 5.0 to 31, causing a unsatisfactory immersion IMHO. I didn't have this problem with the previous build(s) and have tried disabling FO instruments, unlocking FPS to unlimited, and also tried an external limiter with the same results.

 

As I said, I'm fully aware that that my system (i5-2500K oc 4.3 GHz, Z68X-UD4-B3 INTEL, EVGA NVIDIA GTX 570 1.2 GB GDDR5 -Win-7 64 - FSX Box SP2) is outdated to say the least. I do keep it clean and for FSX only, update Windows and video drivers regularly.

 

I'm at a loss and may go back to 5c for performance reasons, but I'm rather fond of the newly added features and fixes of 1.0.1. But I understand it could be just my system.

 

Cheers,

Pete

 

Share this post


Link to post

Nothing wrong with that PC, it's an excellent processor.

 

I actually saw a slight performance increase with the latest version.

 

Two things you might try.  First, each time we update our NVIDIA drivers it's a good idea to delete your FSX or P3D Shaders, which will be rebuilt the next time you launch the sim.  Same goes for your FSX or Prepared CFG file (plus try running the sim/aircraft with zero tweaks under P3D).

 

Also, each time we update our NVIDIA drivers we all risk having problems which can be corrected by doing a graphic drivers uninstall and wipe followed by reinstalling the latest driver.  This often corrects frame rate issues that hit us out of the blue.  You can read more about this and get the wipe tool HERE, but I recommend this as a last resort because in rare cases dong this can cause problems even if you follow the instructions to the letter (though I've never had it happen in all the times I've done it myself or for customers).

 

Looking forward to hearing back from you.

 

 

Share this post


Link to post

The new versions should be marginally faster indeed and I can't explain why it is slower on your system.

Share this post


Link to post

I too have noticed a performance drop with this latest version . Clean install , C++ Redistributable up to date . I5 processor but previous versions were very acceptable . While attempting to descend in speed mode ( 320 kts ) the speed bled off to 260 kts before autopilot reacted . Related to performance issues ?

Share this post


Link to post

I am sorry, but I have to add my voice to this list....in fact, my symptoms are uncannily like those reported by @PeterZ KCLE EDDN. I experience severe stutters with the periodically dropping frame-rates.

Share this post


Link to post

My Setup:

 

i7-4790k - MSI Z97 Gaming 3

MSI GTX 980ti 6Gb GAMING 6G

8Gb Ram DDR3 Corsair Vengeance Pro 2400mhz 

 

tested faster on LOWI ORBX with heavy cloud, fast takeoff and back landing. Stable on 29.8 FPS (locked at 30 FPS).

Only Dynamic Light on ground hit heavy the FPS (15-20 FPS)

Share this post


Link to post

I noticed an overall decrease in frame rate too, but not by much. I can easily live with it, now that everything works as it should.

Share this post


Link to post

Pretty noticeable frame rate drop in FSX-SE. No stutters, though. Varying fps, but no "deep dips", though.

 

Currently the best overall compromise for me and my system would still be 1.0.0.5c - the yoke is "eternal" anyway ...

Share this post


Link to post

Same here using fsx-se.  Lower fps(at least visually) and occasional stuttering.  Windows 7 64 bit with i7 4790k and GTX 960 strix.

Share this post


Link to post
10 hours ago, DaveCT2003 said:

Nothing wrong with that PC, it's an excellent processor.

 

I actually saw a slight performance increase with the latest version.

 

Two things you might try.  First, each time we update our NVIDIA drivers it's a good idea to delete your FSX or P3D Shaders, which will be rebuilt the next time you launch the sim.  Same goes for your FSX or Prepared CFG file (plus try running the sim/aircraft with zero tweaks under P3D).

 

Also, each time we update our NVIDIA drivers we all risk having problems which can be corrected by doing a graphic drivers uninstall and wipe followed by reinstalling the latest driver.  This often corrects frame rate issues that hit us out of the blue.  You can read more about this and get the wipe tool HERE, but I recommend this as a last resort because in rare cases dong this can cause problems even if you follow the instructions to the letter (though I've never had it happen in all the times I've done it myself or for customers).

 

Looking forward to hearing back from you.

 

 

Hello Dave,

 

you're being too kind about my system specs ;-) Thank you for your help, I typically delete my shaders whenever I install new drivers, but I went to NVIDIA to see if I had the latest drivers and apparently I didn't. However, I have seen no improvements unfortunately.

 

I tried turning off Dave, weather and/or terrain radar to see what impact they might have on smoothness and FPS, but again, no noticeable improvements - really strange. 

 

Thanks again for your help Dave, I truly appreciate it.

 

Cheers,

Pete

Share this post


Link to post

You are most welcome my friend.  One thing you can also try is a new Prepared.CFG file, and something else is open P3D and go to the graphics settings and select Default.  I'm told this is different than creating a new CFG file, though I don't really know why it would be.  I know these seem rather benign, but give them a try.

 

Best wishes.

 

 

Share this post


Link to post

@PeterZ KCLE EDDN I did some test flights but couldn't find any change in FPS here. If you experience stutters or micro-stutters, can you please tell me in which frequency you get them? Please also try the same without any other add-ons and somewhere in central africa or anywhere else where you don't have any add-on scenery. I just want to be sure that the drop is really related to the CRJ.

Share this post


Link to post

Terrible performance. While doing an approach into KPVD, with no add-on scenery and an 8 mph wind, speeds were all over the place on the ILS, stuttering as well. FPS all over the place too.

 

I have several aircraft form developers such as PMDG, TFDi, and A2A. None of them perform as badly as this. The stuttering takes the immersion right out of the sim.

 

I'm running an i7-6700 at 4.0G and have a Nvidia GTX 970. 

 

Share this post


Link to post
45 minutes ago, jimst57 said:

Terrible performance. While doing an approach into KPVD, with no add-on scenery and an 8 mph wind, speeds were all over the place on the ILS, stuttering as well. FPS all over the place too.

 

I have several aircraft form developers such as PMDG, TFDi, and A2A. None of them perform as badly as this. The stuttering takes the immersion right out of the sim.

 

I'm running an i7-6700 at 4.0G and have a Nvidia GTX 970. 

 

 

What sim are you running?

 

Have you tried the recommendations above in this thread?

 

Best wishes.

 

Share this post


Link to post

I noticed a loss of about 5 fps here. Never get much more than 20 to begin with so a loss of 5 is pretty harsh for me.

P3d v3

Intel i5

nVidia GTX 980ti

16GB RAM

Windows 7 Pro

Share this post


Link to post
2 hours ago, DaveCT2003 said:

 

What sim are you running?

 

Have you tried the recommendations above in this thread?

 

Best wishes.

 

 

P3D v4. Yes I deleted the cfg file, but I have not tried the "Default Graphics". 

 

It's not the FPS instability, or loss of FPS, but the lack of smoothness while taxing and on approaches that is troublesome. Stuttering.

 

I should mention that I do not have this problem with other high end aircraft in the sim.

 

I also mentioned in an earlier post that the TFDi  717 had very similar problems on my system until they found a "solution" in an update. It's fine now.

 

 

 

Share this post


Link to post
7 hours ago, jimst57 said:

It's not the FPS instability, or loss of FPS, but the lack of smoothness while taxing and on approaches that is troublesome. Stuttering.

 

I understand that you're not having this issue on other high-end aircraft, and I know this is frustrating.  In my opinion, the CRJ is a little tougher on frames over all as it has a lot of things going on that other aircraft in this class don't have.  As such, one's settings really have to be tweaked in to have the type of performance that many of us experience.  Another way of looking at this might be that the CRJ is letting you know that something isn't as tuned as it could be.

 

Have you wiped and then updated your graphics drivers, rebuilt your Prepar3d.cfg and run without any tweaks?  Is your processor or graphics card over-clocked at all (if so, please revert back to normal and re-try).  Can you please take screen shots of your Prepar3d Graphics Settings (both pages). 

 

Also, do you experiencing stutters all the time, or just at certain times?  Do you get stutters at Cruise altitude in clear weather?  The best way to test one's frame rate and smoothness is to get up to/above FL350, switch off any weather engine that is running, and select clear skies in Prepared.  I'd love to know how your system performs under those conditions after doing the above recommendations.

 

I'll be doing another live stream sometime tomorrow morning (Central Time) and you can log in and watch my frame rates and smoothness.  I'm running on an i7-4770K at 4.3GHz under a GTX1080 pushing a 55 inch 4K and three 23-inch LCD monitors. You can register for notification of when my stream starts by "Following" my stream at www.twitch.tv/ovpa.  I also run the TFDi Design B717, PMDG 737/747/777 and many more high-end aircraft.

 

 

 

 

Share this post


Link to post

Personally I'm running a pretty basic system . Good hardware  but only a i5 processor . FSX , stock scenery , medium settings , current drivers , but it performs well with very minimal stutters when taxiing , none on takeoff , cruise or approach using PMDG (737,777,J41) , Aerosoft Airbus , Majestic Q400  . I really can't optimize anywhere else . The initial release of the CRJ was acceptable . For me each subsequent release did not perform as well , particularly on the approach phase  . I appreciate what you are saying but I'm sure people are hesitant to fiddle with their systems if it's already running well with all their other add-ons out of fear of screwing things up . 

If this is the best it will be .. well , it is what it is . It's always a risk for me to purchase a new aircraft with my system . Please don't take this the wrong way but I am curious when you say the CRJ has a lot more going on that other aircraft in this class don't ?

 

Respectfully ..

Share this post


Link to post

Same here! FSX, I noticed a huge FPS loss. Was better 1005 for me, but to go back??

Share this post


Link to post

Same here, too. FSX, not the best hardware, but no problems with CRJ version 1.004 and other addons like PMDG 777, 747, Aerosoft buses. But now huge FPS loss on approach.

Share this post


Link to post

Tried another flight but still poor performance and stuttering in fsx steam edition.  Uninstalled and reinstalled newest 2015 C++ redistributables and updated to latest nvdia driver.  Defragmented hard drives also.  When installing 1.0.1 antivirus was off and ran installer as Admin(I unistalled old version before).  Only thing I did not do was erase any files manually before reinstall.  Maybe have to try that next...  Maybe I'll try deleting shader cache and CFG files next.  Performance was much better with 1.0.0.5c for me.  No stuttering.  Too bad...  Also running ASN with Rex 4 Texture direct Enhanced.  Will try a few things and let you guys know if any improvements.

 

Windows 7 i7 4790K Nvdia GTX 960 STRIX 16 GB RAM

 

John Gaasbeek 

Share this post


Link to post

Just noticed that FSX just changed to its fall colours.  Could this make a difference???

Share this post


Link to post

I just deleted the FSX CFG and Shaders files.  Unistalled the CRJ and found SEVERAL remaining files that I manually deleted.  Rebooted with av turned off and am now downloading the CRJ again as per Dave's recommendations.  Keep you posted...

Share this post


Link to post

Good news!!!  Just did a quick CYOW yo CYUL flight in the 900 (Air Canada) and performance seems to good once again with no stuttering.  Even landing at my Fly Tampa CYUL scenery didn't drop the frame rates too much.  Excellent nav and ils tracking.

Now if I could only hide the yoke...

Share this post


Link to post

×
×
  • Create New...