Jordan Long

Twin Otter Extended: Flight1 vs Aerosoft Store

Recommended Posts

Hello! 

 

I just purchased what looks like an amazing plane on the Flight1 store and had planned on using it for P3Dv4. But when I went to install it, it only seemed to support up to P3Dv2.  I noticed on the aerosoft website it says under the system requirements that it supports v3 and v4.  Did I error buying the plane on the Flight1 website??  Please help!

 

Thank you.

 

-Jordan

Share this post


Link to post
Share on other sites

Hi Jordan, you should ask Flight1, why they are selling an outdated product. As soon as Aerosoft releases a new version it makes it available to all other resellers having a contract with Aerosoft.

So IMHO there are 2 sceneraio:

1. Flight1 is not (or no langer) an authorized reseller

2. they simply forgot to update their shop.

But in any case you have to contact Flight1 to solve this issue.

 

Share this post


Link to post
Share on other sites

1. is certainly not the case. Think they are simply behind with the hundreds of updates flying around at this moment.

Share this post


Link to post
Share on other sites

I know the thread is 1,5 year old, but I almost got the Twin Otter from Flight1 basing on the information here.

However to be on the safe side, I asked the question to their support and here is what Flight1 responded:

 

"The product we sell on behalf of Aerosoft, is compatible with 32-Bit P3D up to version 3.x, it is not compatible with 64-bit P3D v4."

 

So - despite it is cheaper to buy there, I got mine directly from Aerosoft.

It is great product by the way :D

 

Andrzej

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now