Semirben

Fehler auf X-Plane 11 DVD (mit Linux Mint)

Recommended Posts

Hallo zusammen,

 

mir ist ein schwerwiegender Fehler auf der DVD von X-Plane 11 aufgefallen. Beim Starten oder Installieren von X-Plane 11 versucht X-Plane, auf die Datei

Quote

*DVD-Laufwerk*/X-Plane 11/directory.txt.zip

zuzugreifen und diese zu entpacken. Auf der DVD (erhalten heute am 04.04.2017) ist jedoch nur die Datei "directorytxt.zip", also ohne Punkt vor "txt" enthalten.

X-Plane quitiert den fehlenden Punkt mit der Meldung
 

Quote

Error during DVD scan: The installer cannot extract a file. Please report this to X-Plane techincal support at info@x-plane.com, and include the information below:
Error: Error 5:20001.
Compressed File: /media/daniel/XPLANE11/X-Plane 11/directory.txt.zip.
Destination Path: Output/preferences/.
(UTL_installer.cpp:641)

und lässt sich nicht dazu überreden, zu starten.

 

Es würde mich wundern, wenn dieser Fehler nur bei mir auftritt. Angehängt ist meine Log-Datei von X-Plane. Könnte jemand der die Box auch schon hat, bei sich mal nachschauen, wie genau die Datei "*DVD-Laufwerk*/X-Plane 11/directorytxt.zip" benannt ist?

Log.txt

Share this post


Link to post
Share on other sites

Hallo Semirben,

 

ich habe hier 2 Box Sets von X-Plane 11 vorliegen.

Auf beiden DVDs Nummer 1 gibt es einen zip Ordner "directory.txt.zip" .

Installation läuft einwandfrei durch.

inhalt-dvd1.thumb.jpg.15ed6722d3cf154cc86ae75a3d46a3d7.jpg

 

 

Möglicherweise auch ein Lesefehler?

DVD und/oder Laufwerk nochmal säubern vielleicht?

 

Gruß Heinz

 

Share this post


Link to post
Share on other sites

Hallo Heinz,

 

ich nutze primär Linux (auch für X-Plane). Ich habe mir den Inhalt der DVD mal unter Windows (Dualboot auf dem selben Rechner) angesehen und da ist die Datei richtig benannt. Als Änderungsdatum der Datei habe ich bei mir den 06.03.2017 22:52 Uhr. Anbei zwei Bilder, wie das unter Linux Mint 18.1 aussieht

 

dvd1lwup9.png

 

dvd2mfueh.png

Share this post


Link to post
Share on other sites

Hallo,

 

Möglicherweise akzeptiert Linux-Mint keine 2 Punkte ( . ) im Dateinamen.

Wir bekommen die Daten so wie sie jetzt auf der DVD sind von Laminar Research und brennen sie dann. Ändern können wir daran nichts.

Vielleicht gibt es hier ja einen Linux Experten, der eine Idee hat... ?

 

Vielleicht hilft es ja auch, den Installer direkt von X-Plane.com zu laden diesen dann zu verwenden:

http://www.x-plane.com/desktop/try-it/ (One Installer all of X-Plane).

 

Gruß Heinz

 

PS: Ich habe im Titel mal Linux Mint eingefügt. Dann sieht das ein Linux Anwender sicher schneller.

 

 

Share this post


Link to post
Share on other sites

Hallo,

 

um die Installation geht es mir nicht primär (Dank Pressekopie während der Betaphase habe ich alle Dateien schon auf dem Rechner). Es geht mir eher darum, dass ich meine regulär erworbene DVD jetzt leider nicht nutzen kann, was sehr ärgerlich ist. Linux unterstützt problemlos mehrere Punkte im Dateinamen. Ich habe mir jetzt mal den Spaß gemacht und mir ein ISO-Abbild der DVD gezogen und den Dateinamen korrigiert. Ich vermute, dass beim Pressen der DVDs irgendein Format genutzt wurde, was unter Windows keine Probleme macht, aber unter Linux das gezeigte Problem verursacht.

 

dvd3ltu8c.png

Share this post


Link to post
Share on other sites

Ich habe es parallel an Laminar Research gemeldet. Interessant zu wissen wäre, ob das nur bei mir auftritt oder auch andere Nutzer von Mac und/oder Linux das Problem haben

Share this post


Link to post
Share on other sites

Das Interessante ist, dass die X-Plane 10 DVD problemlos funktioniert. Ich werde heute abend testen, ob das Problem auch unter einer Ubuntu-Umgebung und einer Live-DVD von Mint auftritt oder ob es ein lokales Problem bei mir auf dem Rechner ist.

Share this post


Link to post
Share on other sites

Mittlerweile gibt es auch andere Meldungen von anderen Linux-Nutzern, sowohl mit Mint als auch mit Arch Linux. Die liegen mir im Ticketsystem vor.

 

Ich werde auch nochmal den Fehler melden sowie Laminar direkt anschreiben dafür.

Share this post


Link to post
Share on other sites

Nur der Vollständigkeit halber. Gleiches Problem unter Ubuntu 16.04 und einer frischen Mint 18.1 Installation. Sieht ganz so aus, als wäre da beim Dateisystem der DVDs irgendwas schiefgelaufen

Share this post


Link to post
Share on other sites

Das Problem scheint allgemein auf alle Linuxsysteme zuzutreffen.

Bei mir unter Open Suse Leap 42.2 tritt es ebenfalls auf.

Share this post


Link to post
Share on other sites

Guten morgen zusammen,

 

ich habe jetzt mit Ben Supnik an einer Lösung gebrütet und so wie es aussieht, kommen wir dem Problem so langsam näher. Zuerst: Man kann die DVD als DRM "relativ" simpel zum Laufen kriegen. Das erfordert aber eine kleine Zeile im Terminal. Schuld sind die sogenannten "Rock-Ridge extensions". Wenn man die DVD nun mittels

Zitieren

sudo mount /dev/sr0 -o norock /mnt

mountet, hat man die fehlende Groß-/Kleinschreibung wieder und auch die Dateierweiterungen der gezippten Windows-Executables ist wieder da. Damit kann man nun die DVD wieder nutzen, um X-Plane zu starten. Wie das bei der Installation aussieht, muss ich heute Abend mal testen. Wenn alles gut läuft, haben wir diese Woche noch einen angepassten Installer, der diese Probleme umgeht.

 

Viele Grüße,

Daniel

Share this post


Link to post
Share on other sites

Da ein Bearbeiten meines vorherigen Posts leider nicht mehr möglich ist:

 

Die Installation geht auch, wenn man beim DVD-Wechsel die DVD entsprechend mit obigem Kommando mountet

Share this post


Link to post
Share on other sites

Hallo Daniel,

 

danke für die Info. 

Inzwischen haben wir auch von Ben die Bestätigung, dass hier ein Problem unter Linux vorliegt. Unabhängig von der Distribution....

Wie Du auch schriebst, arbeitet Ben an einem angepassten Installer.

 

Viele Grüße

 

Share this post


Link to post
Share on other sites

Vielen Dank an alle Beteiligten für die prompte Lösung des Problems.

Die Installation verlief reibungslos und ich kann das neue  beeindruckende

X-Plane genießen!

Viele Grüße

Gerhard

Share this post


Link to post
Share on other sites

Schön, dass ich diesen Beitrag gefunden habe. Und gut, dass es dafür eine Lösung gibt.

 

Nicht gut ist, dass dieses Problem immer noch bei den DVDs besteht, die ich vor einer Woche zum Geburtstag geschenkt bekommen habe.  Das hat mich nun einen halben Tag gekostet, und die Freude auf den arbeitsfreien Samstag und die Installation des Simulators ordentlich vergällt.

 

Wie kann das denn sein? Ist der Fehler noch nicht behoben?

 

Das wüsste ich gerne!

Share this post


Link to post
Share on other sites

Die Lösung scheint hier keine zu sein. Ich habe die DVD genau so gemountet, wie beschrieben. Ich bekomme dann trotzdem den Installationsfehler. Wenn ich das fragliche Directory liste, ist die Datei aber da.

 

Im Screenshot sieht man links im schwarzen Fenster die Fehlermeldung, rechts im xterm das directory-listing, und noch mal extra gelistet die

 

/media/cdrom/X-Plane\ 11/directory.txt.zip


Die Blackslashes im Bild dienen nur der Entwertung der Leerzeichen (die in Dateinamen sowieso äusserst lästig sind).

 

Was nun?

 

 

PS: /media/cdrom und /media/cdrom0 ist dasselbe.

 

 

snapshot1.jpg

Share this post


Link to post
Share on other sites

Also ich habe gefunden, woran es liegt.

 

Wenn die Installation mit den entsprechenden mount-Optionen  zunächst startet, dann aber - warum auch immer - abbricht, dann bleibt im /tmp directory Schrott zurück: Eine entpackte /tmp/directory.txt

 

Hatte man die Installation in seiner Verzweiflung nun als 'root' ausgeführt, kann diese Datei bei einem Neuversuch unter anderem Namen nicht gelöscht werden, was zunächst ja auch kein Fehler von X-Plane ist. Genau das war hier das Problem.

 

Der Fehler ist die Meldung selber. Sie sagt zwar nicht Falsches aus, gibt aber keine Auskunft über die Ursache. Angesichts der des rockridge-extensions Problems neigt man dann natürlich zu anderen mysteriösen Erklärungen.

 

Da wäre eine Meldung wie "Existing file /tmp/directory.txt can not be overwritten" eine echte Erleuchtung.

 

Mal sehen, wie weit ich nun komme, immerhin gint es ja einen Workaround.

 

Dennoch möchte ich gerne wissen, ob der Fehler auf aktuellen DVDs immer noch besteht, oder ob er zwischenzeitlich behoben wurde. Denn ein 'mount' mit gesonderten Optionen kann für die DVD mit den standardmäßig vergebenen Rechten unter Linux nur als root ausgeführt werden.

 

Das ist definitiv keine Option.

Share this post


Link to post
Share on other sites

Es ist mühsam.

 

Die erste DVD hat der Installer installiert. Gewählt waren alle Szenerien weltweit.

 

Der Installer installiert offenkundig die Software, verabschiedet sich aber lautlos ohne weitere DVDs anzufordern. EIn erneuter Aufruf kommt bis zum Auwahlbildschirm der Szenerien, alsa die Weltkarte. Dort habe ich dann, nun schgon deutlich bescheidener, nur Europa angeklickt.

 

Gleiche Reaktion: Der Installer verschwindet sang- und klanglos.

 

Die Protokolldatei ist angehängt.

 

Die Ausgabe auf dem xterm (Kommandozeilen-Fenster) sieht so aus:

 

ed@simbox:/tmp$ /media/cdrom/x-plane\ 11\ installer\ linux
Launched PID: 11402
Segmentation fault
ed@simbox:/tmp$ *   Trying 172.217.16.206...
* Connected to www.google-analytics.com (172.217.16.206) port 80 (#0)
> POST /collect HTTP/1.1
Host: www.google-analytics.com
User-Agent: X-Plane Installer 4.02r2-final-LIN_64bit
Accept: */*
Content-Type: application/json
Content-Length: 319

* upload completely sent off: 319 out of 319 bytes
< HTTP/1.1 200 OK
< Access-Control-Allow-Origin: *
< Date: Sat, 22 Jul 2017 17:15:23 GMT
< Pragma: no-cache
< Expires: Fri, 01 Jan 1990 00:00:00 GMT
< Cache-Control: no-cache, no-store, must-revalidate
< Last-Modified: Sun, 17 May 1998 03:00:00 GMT
< X-Content-Type-Options: nosniff
< Content-Type: image/gif
< Server: Golfe2
< Content-Length: 35
< 
* Connection #0 to host www.google-analytics.com left intact
Checksum Reader: 24.3% wait input, 75.0% work, 0.7% wait output.
Checksum calc: 98.4% wait input, 0.0% work, 1.6% wait output.
Start time: 11.668020

In der dritten Zeile ein segfault (i.e. Crash mit Absturz). :wacko:

 

Hier die /var/log/kern.log Einträge dazu:

 

Jul 22 18:15:54 simbox kernel: [18640.195851] traps: X-Plane 11 Inst[11402] general protection

    ip:584752 sp:7ffc0a7d2998 error:0 in X-Plane 11 Installer Linux[400000+683000]
Jul 22 18:16:56 simbox kernel: [18702.489880] X-Plane 11 Inst[11432]: segfault at 968

    ip 00007f3b62d186cc sp 00007ffe59306ec0 error 4 in libX11.so.6.3.0[7f3b62cd8000+13c000]

 

Das System ist neu aufgesetzt und aktuell:

 

ed@simbox:~$ uname -a
Linux simbox 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 GNU/Linux

 

Trotzdem erscheint der Installer. Alles Weitere geschieht dann wie zuvor beschrieben.

 

Was nun?

 

Share this post


Link to post
Share on other sites

Hallo D-EMAX,

 

leider bin ich kein Linux Experte.

Wenn Du die "Lösung" aus Post 19 (mit dem hier benannten Linux Installer) genau durchgeführt hast, und auch die "mount" Lösung nicht klappt, dann solltest Du einmal den aktuellen Installer verwenden (falls nicht schon geschehen):

http://www.x-plane.com/desktop/try-it/ (ONe Installer, All Of X-Plane).

 

Ich verschiebe den Post auch einmal in den Linux Forum Teil. Möglicherweise bekommen wir da mehr Hilfe von Linux Usern sofern einige auch das Problem haben....

Ansonsten kann da wohl nur Laminar Research selbst helfen.... 

 

Normalerweise sollte aber die Lösung aus Post 19 helfen.

 

Gruß Heinz

 

Share this post


Link to post
Share on other sites

Hi D-EMAX,

 

probiere bitte mal den gefixten Installer aus dem Blog (http://developer.x-plane.com/2017/04/linux-and-aerosoft-dvds-and-fixed-apps/) https://www.dropbox.com/s/q9y5x00walgxbcn/fixed_linux_installer.zip?dl=0

Damit war zumindest bei mir eine problemlose Installation mit dem DVDs möglich. Die gefixte Executable für X-Plane 11 brauchst du, nachdem du X-Plane entsprechend geupdatet hast, nicht mehr.

 

Viele Grüße,

Daniel

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

besten Dank für die Antworten.

 

Beim Installationsaufruf wird automatisch ein neuer Loader aus dem Web gezogen, und dann aufgerufen. Das sollte dann eigentlich die neueste Version sein.

 

Ich mache nun Folgendes: Ich lege eine neue Partition auf demselben Rechner an, und installiere dort Ubuntu 16.04. Der 'segfault' aus der Installation lässt mir keine Ruhe, es könnte nämlich auch an meiner Version der libX11 liegen. Um das auszuschließen, werde ich eine Probeinstallation auf der Ubuntu-Partition machen, und dann sehen wir weiter.

 

Wenn es dann klappt, liegt es an der lib. Andernfalls muss wohl Laminar Research ran. Ich helfe gerne, wo ich kann. Denn wenn Linux-Installationen zu problematisch daherkommen, gibt es irgendwann keine Linux-Version mehr, was ziemlich übel wäre.

 

Allerdings, das muss ich schon sagen, ist die DVD so wie sie erstellt ist ein Armutszeugnis, so was muss nicht passieren. Da frage ich mich (einmal mehr), ob Hersteller das Zeug, dass sie ausliefern, nicht auch mal selber testen?

 

Zu meinen DVDs: Die hat mein Sohn anfang Juli in Darmstadt gekauft, könnte also ein veralteter Lagerbestand sein. Das ist natürlich nicht so prickelnd, ich hätte gerne 'ordentlich' installierbare Versionen (wobei mein aktuelles Problem mit der libX11 möglicherweise eine andere Geschichte ist, aber daran arbeite ich ja).

 

Wenn ich mehr weiß. melde ich mich wieder.

 

 

VG

Edgar

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now