Jump to content

X-Plane 10.50 Beta/RC: Diskussionen


Heinz Flichtbeil

Recommended Posts

  • Administrator

Hallo,

 

da ja nun wieder ein Beta Prozess X.Plane 10.50 läuft, denke ich, ist es am Besten hier alles an einer Stelle zu posten.

Möglicherwese finden wir hier auch "workarounds", die ersteinmal weiterhelfen ....

Bitte aber daran denken, dass 10.50 im Beta Stadium ist. Das bedeutet, es kann und wird zu Problemen kommen, die im Beta Prozess dann bereinigt werden sollen, was der Sinn einer Beta Version ist.

Eine Beta Version ist nicht zum reinen und problemlosen Fliegen gedacht.

Dafür bitte die Version 10.45 verwenden.

 

Gruß Heinz

Link to comment
Share on other sites

  • Replies 106
  • Created
  • Last Reply

Habe sofort die neue beta 150 installiert. startet wunderbar. die tastenbelegungen haben sich verändert (neue zuordnung funktioniert). bis jetzt läuft alles sehr gut. leider stürzt der planemaker bien start ab. habe nun den planemaker von der 145er verwendet.

Link to comment
Share on other sites

Vor 1 Stunde, hrsoft sagte:

habe nun den planemaker von der 145er verwendet.

 

Wenn du Flugzeuge erstellst, würde ich auf jeden Fall erstmal bei der letzten stabilen Version bleiben, auch zum Testen dieser Flugzeuge, bis wirklich klar ist, dass 10.50 mit allen Teilen wirklich gut funktioniert. Zurzeit gibt es ja, wie bei einer Beta zu erwarten, noch viele Bugs...

Link to comment
Share on other sites

vor 2 Stunden , hrsoft sagte:

Habe sofort die neue beta 150 installiert. startet wunderbar. die tastenbelegungen haben sich verändert (neue zuordnung funktioniert). bis jetzt läuft alles sehr gut. leider stürzt der planemaker bien start ab. habe nun den planemaker von der 145er verwendet.

I kann den Absturz bestätigen beim öffen eines Flugzeuges

 

Gruss

 

Wolfgang

Link to comment
Share on other sites

vor 4 Minuten, Mario Donick sagte:

 

Zeig doch mal deine log.txt :) 

ich müsste das heute Abend zuhause nochmals nachstellen. Ich hatte die Scenery LSZHv2 danach disabled, 10.50 funktioniert dann mit der default-scenery, hatte dann aber wieder aus anderen Gründen crashes (z.b. gibt es auch einen Absturz mit FSGRW, ist ja auch erst die b1).

Link to comment
Share on other sites

vor 2 Minuten, wodec sagte:

I kann den Absturz bestätigen beim öffen eines Flugzeuges

 

Und auch an dich die Bitte, mal deine log.txt zu zeigen. Sie ist im X-Plane-Ordner und enthält u.U. Ursachen für den Absturz.

 

Allgemein ist es aber so, dass X-Plane 10.50 nur eine Beta-Version ist, bei der man mit genau solchen Problemen rechnen muss. Oft sind z.B. auch einfach irgendwelche Plugins noch nicht auf die neue Version hin abgestimmt (kompatibel). Beta-Versionen sind daher nicht für den normalen Einsatz gedacht, sondern zum Finden von Fehlern. Fehler können an Laminar hier gemeldet werden:

 

http://dev.x-plane.com/support/bugreport.html

Link to comment
Share on other sites

  • Deputy Sheriffs

@Mario Donick Ich hatte Abstürze beim Start, dank des Hinweises von Mario (Seatraffic und GroundServices als mögliche Ursachen), konnte ich SeaTraffic bei mir als Übeltäter identifizieren, GroundServices habe ich nicht.

 

Also Seatraffic verschoben, schon läuft die 10.50b1. Bisher hatte ich keine weiteren Probleme.

Link to comment
Share on other sites

Ben Supnik von Laminar hat einen Überblick über vorhandene Bugs gegeben:

 

http://developer.x-plane.com/2016/06/some-bugs-in-x-plane-10-50-beta-1/

 

  • Das neue Autogen fehlt, wegen eines Fehlers im Installationsprogramm
  • Manche Custom Scenery führt zu Abstürzen
  • Rollwegmarkierungen (taxi lines) fehlen
  • Manchmal schweben Objekte in der Luft
  • die neuen statischen Flugzeuge funktionieren auch nicht
  • im Zusammenhang mit diversen Plugins kommt es auch zu Abstürzen

 

Ben geht davon aus, dass in den nächsten paar Tagen Beta 2 rauskommen wird.

Link to comment
Share on other sites

  • Administrator

Wurde denn auch der aktuelle Installer/Updater verwendet. Das müsste 3.40r3 sein.

http://www.x-plane.com/downloads/x-plane_10_installer-updater/

Vielleicht diesen auch einmal als Admin (rechte Maustaste) ausführen.

 

Ansonsten ist die Log.txt Datei (wie Mario schon sagte) immer wichtig....

Gruß heinz

Link to comment
Share on other sites


 

vor 6 Stunden , Mario Donick sagte:

 

Zeig doch mal deine log.txt :) 

 

Hallo Mario

 

Es scheint an der "Aerosoft LSZH Airport Zurich V2.0 c" zu liegen, wenn ich diese disable, started xplane.

Im log.txt stand folgendes:

...

....

0:00:00.000 I/SCN: DSF load time: 55388 for file Custom Scenery/Global Airports/Earth nav data/+40+000/+46+008.dsf (0 tris)
0:00:00.000 I/SCN: DSF load time: 163265 for file Custom Scenery/w2xp_Europe/Earth nav data/+40+000/+46+008.dsf (0 tris)
0:00:00.000 I/SCN: DSF load time: 22291282 for file Custom Scenery/zzz_uhd_global_scenery1/Earth nav data/+40+000/+46+008.dsf (3930213 tris)
0:00:00.000 E/OBJ: The object Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 a/Objects/Vehicles/staticaircrafts/CRJ700_misc.obj has unbalanced anim begins.
0:00:00.000 I/SCN: DSF load time: 2931735 for file Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 a/Earth nav data/+40+000/+47+008.dsf (0 tris)
0:00:00.000 I/SCN: DSF load time: 126286 for file Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 b/Earth nav data/+40+000/+47+008.dsf (0 tris)
0:00:00.000 E/SCN: Failed to find resource 'test/AGtrees_test.for', referenced from file 'Resources/default scenery/airport scenery/Common_Elements/Misc_Buildings/'.
0:00:00.000 I/SCN: DSF load time: 192505 for file Custom Scenery/Global Airports/Earth nav data/+40+000/+47+008.dsf (0 tris)
0:00:00.000 I/SCN: DSF load time: 2361902 for file Custom Scenery/w2xp_Europe/Earth nav data/+40+000/+47+008.dsf (0 tris)
0:00:00.000 I/SCN: DSF load time: 6300529 for file Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 c/Earth nav data/+40+000/+47+008.dsf (1158716 tris)
--=={This application has crashed!}==--

 

 

Gruss

Ernst

 

 

 

 

 

Link to comment
Share on other sites

vor 10 Minuten, ernesto99 sagte:

0:00:00.000 I/SCN: DSF load time: 6300529 for file Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 c/Earth nav data/+40+000/+47+008.dsf (1158716 tris)
--=={This application has crashed!}==--

 

Hallo Ernst,

 

ja, das sieht wirklich so aus, als stürzt X-Plane beim Laden des Tiles dort ab.

 

Ben hat geschrieben, dass X-Plane 10.50 beta 1 beim Laden mancher Szenerien abstürzt, ich vermute, das ist so ein Fall, denn in 10.45 funktioniert Zürich ja problemlos. Er hat auch geschrieben, dass das (und die anderen oben genannten Bugs) in beta 2 behoben sein sollen. Ich würde erstmal solange abwarten, soll ja nicht sehr lange dauern. :-)

Link to comment
Share on other sites

  • Deputy Sheriffs

Nein, " Aerosoft LSZH Airport Zurich V2.0 c " wird ja laut Log noch fehlerfrei geladen, es ist eine Szenerie, die danach kommt, muss aber nicht in der Reihenfolge der scenery_packs.ini sein. Da hilft nur vermuten und ausprobieren.

 

Ich hatte bisher keine Probleme mit Szenerien, war aber auch noch nicht überall. ;) Bei meinen Sachen wie w2xp-Szenerien, Europe_Library und O4XP gibt's keine Schwierigkeiten. :) 

Link to comment
Share on other sites

vor 28 Minuten, PilotBalu sagte:

Nein, " Aerosoft LSZH Airport Zurich V2.0 c " wird ja laut Log noch fehlerfrei geladen

 

Aber wenn er LSZH deaktiviert, lädt es fehlerfrei... vielleicht ist es auch eine Kombination von LSZH mit anderen Szenerien, die nicht richtig will.

Link to comment
Share on other sites

Zitieren

Die Fehlermeldung beklagt fehlende Zugriffsrechte... Sind das Laufwerk oder der X-Plane-Ordner schreibgeschützt?

 

Hab denÜbeltäter schon gefunden. Aber Danke Mario

 

Real Terra Haze

Sea Traffic

 

gehen schon mal nicht. Wobei RTH am meisten schmerzt, aber es wird hoffenlich bald ein Update raus kommen.

Link to comment
Share on other sites

Real Terra Haze  steigt mit " Lua stopped " aus, man kann aber mit

"Try to resume Lua engine" die letzte Einstellung wieder auf den

Schirm bringen.

Ich habe noch eine 10.45 Version ,dort mache ich meine Einstellungen

und kopiere die *.txt Dateien nach 10.5 .

Leider habe ich den Schlüssel der *.txt Dateien noch nicht herausgefunden.

mfg Hans

Link to comment
Share on other sites

  • Administrator

Noch einmal zu Zürich V2.

Wenn ich nur das Mesh von Zürich V2 deaktiviere, dann lädt X-Plane 10.50 einwandfrei. Unabhängig von der Einstellung der Funktion "Runway Follow Terrain Contours".

Das ist Teil c:

In der Scenery_packs.ini dann so:

SCENERY_PACK_DISABLED Custom Scenery/Aerosoft LSZH Airport Zurich V2.0 c/

Der Fehler scheint also nur mit dem Mesh zusammenzuhängen, welches bei Zürich V2 einige Besonderheiten hat (Tunnel auf dem Apron usw...). Das passt aber zu anderen Problemen....

 

Ich denke auch, wir warten einfach einmal die nächsten Betas ab.....

Trotzdem melde ich das mal an den Entwickler von Zürich V2.

 

Gruß Heinz

 

 

Link to comment
Share on other sites

Der Grund für die Plugin-Abstürze in 10.50b1 wurde gefunden -- und er geht weit, weit zurück ins Jahr 2000, in die Zeiten von X-Plane 6:

 

http://developer.x-plane.com/2016/06/the-anatomy-of-a-plugin-crash

 

Wichtig dabei: Es sind nicht die Plugins, die schuld sind, sondern X-Plane selbst, und es wird in Beta 2 behoben sein.

 

Bens ausführlicher Blogeintrag erklärt sehr schön, wie kleine Änderungen im Programmcode sehr große Auswirkungen haben können. Hier besteht das Problem konkret darin, dass das Dateiformat für 3D-Objekte (das OBJ-Format) sogenannte bedingte Anweisungen (conditional statements) erlaubt. Ben nennt als ein Beispiel unter mehreren die Schatten statischer Flugzeuge. Die 3D-Objekte statischer Flugzeuge können eigene Schatten mitbringen. Wenn der Nutzer aber in X-Plane die Echtzeitschatten aktiviert hat, werden die fest eingebauten Schatten nicht geladen, damit man keine doppelten Schatten sieht. In dem OBJ des jeweiligen Flugzeugs ist dafür eine Wenn-Dann-Verzweigung (if/then), sozusagen "wenn der Nutzer keine Schatten aktiviert hat, dann lade die fest eingebauten Schatten des Objekts, ansonsten lade sie nicht."

 

Das Problem besteht nun darin, dass X-Plane diese Wenn-Dann-Verzweigungen aus OBJ-Dateien schon so früh beim Programm- oder Pluginstart lädt, wenn X-Plane noch gar nicht so weit ist, mit diesen Verzweigungen umzugehen (das conditional system ist noch nicht initialisiert). Dadurch dann der Crash. Und weil das Laden der OBJ-Dateien durch Plugins angestoßen wurde, sieht es dann in der log.txt so aus, als wäre ein Plugin abgestürzt, obwohl es X-Plane selbst war.

 

Bisher wurde dieser Fehler nicht bemerkt, weil bis X-Plane 10.45 solche Verzweigungen nur selten benutzt wurden. Aber in X-Plane 10.50 wird dieses System für jede geladene OBJ-Datei benutzt, selbst es in der OBJ-Datei gar keine Wenn-Dann-Verzweigungen gibt. Das ist jetzt so, um einige andere Bugs zu beheben. Zum Beispiel war es beim Wechsel von Nicht-HDR zu HDR so, dass zwar eine Menge Objekte neu geladen wurden, aber z.B. bestimmte Lichter fehlten, sodass man X-Plane erst neu laden musste, damit man die volle Beleuchtung sieht (weil nur beim Programmstart die entsprechenden Wenn-Dann-Verzweigungen geprüft wurden). Damit sowas nun auch ohne Neustart geht, wird das jetzt immer geprüft, und damit hat man aber VIEL mehr Situationen, in denen der alte Bug aus X-Plane-6-Zeiten zum Tragen kommt.

Link to comment
Share on other sites

Interessant ...

 

Ich habe mir die Beta heute mal installiert und Seatraffic schon deaktiviert, weil ich gelesen hatte, dass es damit zu Problemen kommt. Ich hatte aber immer noch Probleme und zwar mit dem Python-Interface. Kam mir schon etwas seltsam vor, da andere nicht davon berichtet hatten. Jetzt weiß ich, dass ich nur dachte, dass es Python war ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...