Jump to content

Archived

This topic is now archived and is closed to further replies.

Premek

Mega Airport Prague - advisory thread

Recommended Posts

2 hours ago, Terblanche said:

THINK I'VE FOUND A FIX

RE: missing ground textures and jetways

:excl: NB!! Please, please if you don't know how to do the following please don't attempt it and wait until there is an official patch from Aerosoft / XHT-labs

  1. Uninstall ALL airports that use APC - in my case it is Split, Zurich, and Prague ... [don't just delete folders, do a proper uninstall] ... ... I don't know what other airports are using it, maybe Premek could be of assistance.
  2. Make backup of your fsx.cfg and open it. Make sure under [MAIN] that above 3 are not there anymore and that the SimObjectPaths are numerical in order i.e. from 0 to whatever. Then go to [Trusted] and make sure the line C:\FSX\Aerosoft\AirportController\APController.exe.****** is not there anymore
  3. Open your exe.xml file in same folder as fsx.cfg and delete the following 
    <Launch.Addon>
            <Name>XHT.APController</Name>
            <Disabled>False</Disabled>
            <ManualLoad>False</ManualLoad>
        <Path>C:\FSX\Aerosoft\AirportController\APController.exe</Path>
    </Launch.Addon>
  4. Delete the whole AirportController folder under the Aerosoft folder in your FSX - [this is important!]
  5. First install Prague seeing that it has the latest APController files
  6. Run FSX and when prompted ADD the APController module as trusted. Load FSX ... you will probably get an "APController has stop working" the first time ... just continue and load your flight with aircraft on LKPR tarmac. The ground textures and jetways are still missing. Close FSX
  7. Load FSX again and this time APController will load and it will run through and the ground textures and jetways are back.
  8. Now install Split and Zurich or whatever other airport you have that is using APC

On my machine after an hour of testing, the flight loads every time [touch wood] without APController crashing and the ground textures and jetways are back.

@Premek After my reinstall of everything there are far less files in the AirportController folder with special note that previously there was *.dll files with the airport ICAO code that are not there anymore. It could be that if you attempt to install APController within an existing AirportController Folder that something gets mixed up. Now that the latest ACP is installed it seems to work. As I say - touch wood! :rolleyes: 

Just one more time:

:excl:  NB!! Please, please if you don't know how to do this then don't attempt it and wait until there is an official patch from Aerosoft / XHT-labs

 

Hope this helps.

Regards and happy flying in and out LKPR

Terblanche

 

Hi Terblanche

 

I'm really glad yo got it working! And MANY thanks for all your effort!

 

Still I'd not suggest it as standard approach as I have suspission something was squeezed - however it happened.

I'll give it a though and if you don't mind, I'll try to re-structure it and place it as one of the possible points to first post.

 

For instance:

2 hours ago, Terblanche said:

After my reinstall of everything there are far less files in the AirportController folder with special note that previously there was *.dll files with the airport ICAO code that are not there anymore.

But those files are MANDATORY for proper function.... :-|

Share this post


Link to post
Share on other sites

@Premek - I don't mind at all if you want to pin it to your first post and please feel free to edit, add, cut, or rework it in more understandable format.

 

I made a mistake with the ResourcesLKPR.dll and other files. They were not there after first install and I didn't check again after I installed all the scenery again. There are three for Croatia (with Split scenery I presume), one for LKPR and one for LSZH. There are however less files than before that I know for sure. There are 24 in the AirportController folder now. I'm just happy it is a step in the right direction. Maybe part of my OCD personality (LOL) but I could not rest until FSX is working again as it should.

 

Now, what about those runway lights that APC airports are using ......????????

Just joking, let's first fix this and the AFCAD file, then we can start a fresh new demands :D

Share this post


Link to post
Share on other sites
vor 42 Minuten, Terblanche sagte:

@Premek - I don't mind at all if you want to pin it to your first post and please feel free to edit, add, cut, or rework it in more understandable format.

 

I made a mistake with the ResourcesLKPR.dll and other files. They were not there after first install and I didn't check again after I installed all the scenery again. There are three for Croatia (with Split scenery I presume), one for LKPR and one for LSZH. There are however less files than before that I know for sure. There are 24 in the AirportController folder now. I'm just happy it is a step in the right direction. Maybe part of my OCD personality (LOL) but I could not rest until FSX is working again as it should.

 

Now, what about those runway lights that APC airports are using ......????????

Just joking, let's first fix this and the AFCAD file, then we can start a fresh new demands :D

AFCAD?  Take a look!

 

Share this post


Link to post
Share on other sites

@masterhawk ... ah thank you, will give it a try. I started last night to edit the AFCAD but gave up because there is simply too much to fix and I was obsessed to sort out the texture problem (LMAO)

Glad to see you've tackled it. I'm sure @Premek will have it 100% soon.

It's been a while since FSX produced such a challenge, must say the cobwebs are nice and clean again :blink:

 

Terblanche

Share this post


Link to post
Share on other sites
vor 25 Minuten, Terblanche sagte:

@masterhawk ... ah thank you, will give it a try. I started last night to edit the AFCAD but gave up because there is simply too much to fix and I was obsessed to sort out the texture problem (LMAO)

Glad to see you've tackled it. I'm sure @Premek will have it 100% soon.

It's been a while since FSX produced such a challenge, must say the cobwebs are nice and clean again :blink:

 

Terblanche

Thanks, but most work was done by Er!k.

Share this post


Link to post
Share on other sites

I found the solution for the missing runway markings. While reinstalling LKPR, I noticed that also UT2 stopped working. So I checked the simobjects.cfg file and found out that the entries for UT2, Prague and Split where changed and not in sequence (see below). SO I've put the correct entry numbers (11, 12, 13) and runway markings returned.

{Entry.8]
PATH=SimObjects\Misc
TITLE=Default Misc
ACTIVE=true
REQUIRED=true
[Entry.9]
PATH=SimObjects\Submersible
TITLE=Default Submersible
ACTIVE=true
REQUIRED=true
[Entry.10]
PATH=SimObjects\Weapons
TITLE=Default Weapons
ACTIVE=true
REQUIRED=true
[Entry.12]
PATH=SimObjects\UT2 Aircraft
ACTIVE=true
REQUIRED=true
[Entry.14]
Title=Split X
Path=Aerosoft\Split X\simobjects
Required=True
Active=True
[Entry.15]
Title=Mega Airport Prague
Path=Aerosoft\Mega Airport Prague\simobjects
Required=True
Active=True

Share this post


Link to post
Share on other sites
12 hours ago, Terblanche said:

Now, what about those runway lights that APC airports are using ......????????

Well - even though four airports (Split, Zurich, Berlin-Tegel and Prague) uses the APC, all the graphical stuff is done by different developers. Prague is ours (XHT, Artoo) others are Aerosoft.

On which airport(s) you do not like the lights?

 

12 hours ago, Terblanche said:

@Premek - I don't mind at all if you want to pin it to your first post and please feel free to edit, add, cut, or rework it in more understandable format.

Thanks!

Share this post


Link to post
Share on other sites
10 hours ago, gforce800 said:

Looks like i found another bug.

That stuff looks to be caused by FSX/P3D engine itself. Also, suspicious, it has something to do with particular GPU/Driver.

Please hit 'Esc' key twice quickly - should be okay then.

Share this post


Link to post
Share on other sites
8 hours ago, dragos.berzovan said:

I found the solution for the missing runway markings. While reinstalling LKPR, I noticed that also UT2 stopped working. So I checked the simobjects.cfg file and found out that the entries for UT2, Prague and Split where changed and not in sequence (see below). SO I've put the correct entry numbers (11, 12, 13) and runway markings returned.

 

Nice job Dragos! This is one of the points I check when people sending me the CFG files.

Do you still have the original one? Before installed Prague for first time? It would help to identify the issue.

Share this post


Link to post
Share on other sites

@Premek - I know runway lights are a personal preference but as a pilot myself there are a certain 'feel' to runway lights no matter where you land. The older Aerosoft airports have that feel ... EDDM, EDDL, the German 1, 2, and 3 airports. All of them using the same halo.bmp file from your main textures folder. Lately it seems with new scenery that the runway lights are blinking, shimmering, blurry and only on short finals it starts to look like runway lights in real life and even then it seems very sterile...

Years ago I've created a halo.bmp file that I still use. Far from perfect but with the older airports it works fine and is clear from a distance and not overwhelming. I will include it and maybe some of you would like to give it a try. Just backup the one you have and copy this to your main textures folder. But, as I say, it seems the new airports are doing, using something else with the runway lights or are they still halo.bmp dependent?

Have a jump-happy Thursday

Terblanche

 

Runway Lights:

halo.bmp

Share this post


Link to post
Share on other sites

@Terblanche Thanks but we do not use default lights at all.

Again the question - do you find light from all four airports to be the same?

Share this post


Link to post
Share on other sites
1 hour ago, Premek said:

@Terblanche Thanks but we do not use default lights at all.

Again the question - do you find light from all four airports to be the same?

 

It is not as much "default lights" as the colouring (because of the halo.bmp) stays more or less the same. If you land for example at LIME (Bergamo) the the runway lights are typical from Italian airports, more blue-green ... if you land at EGLL (Heathrow) from UK2000 the lights are different again and BOTH are using the halo.bmp but utilise it differently. Don't know if I explain myself correctly. Difficult if English is your 4th language ... :huh:

I did notice lately that all the new airports have this shimmering bleek blurry approach lights and becomes only clearer when you are really close. Or maybe it is just me. May I ask, how do you do your approach, runway, and taxi lights?

Thank you Premek for your continued support and reply.

Have a good day

Share this post


Link to post
Share on other sites

Hi Premek,

just downloaded and installed 1.02. Everything looks outstanding now, thank you very much for your wonderful piece!:clapping_s:

Just looking very forward to the new groundhandling. A last word: your support is fantastic. This kind of support I'd like to have from other developers too!

 

Kai

Share this post


Link to post
Share on other sites

A new version? Great!

 

Hope Simmarket having soon.

Share this post


Link to post
Share on other sites

I must say that I have the similar feelings regarding blurry/shimerring approach lights as Terblanche. In my case it's in P3D v2.5 - if closer you are, they are better a little bit. Maybe it sounds strange but sometimes I even think thay they are even too sharp. So far I thought that it may be caused by specific sim settings or GPU / GPU drivers. In case of lights Copenhagen seems to be my favourit one. 

 

One must be said and emphasized for sure - performance of Prague scenery seems to be one of the best for such airports. :)

Share this post


Link to post
Share on other sites
10 minutes ago, Martin_Starski said:

I must say that I have the similar feelings regarding blurry/shimerring approach lights as Terblanche. In my case it's in P3D v2.5 - if closer you are, they are better a little bit. Maybe it sounds strange but sometimes I even think thay they are even too sharp. So far I thought that it may be caused by specific sim settings or GPU / GPU drivers. In case of lights Copenhagen seems to be my favourit one. 

 

One must be said and emphasized for sure - performance of Prague scenery seems to be one of the best for such airports. :)

 

I have P3D v3.2, and I haven't noticed anything like that. But maybe I have not been paying attention to it.

Share this post


Link to post
Share on other sites

Hi, Kai! What has happened update? GSX has been running?

 

Best regards to you and Premek!

Share this post


Link to post
Share on other sites
22 minutes ago, yushpe said:

GSX has been running?

Yes.

1 hour ago, Kai-Uwe said:

A last word: your support is fantastic. This kind of support I'd like to have from other developers too!

Thanks for kind words - after the last week this is highly appreciated ;-)

Share this post


Link to post
Share on other sites

@Premek - thank you for the V1.02 update ... although I'm a bit hesitate to upgrade because everything is working perfectly now.

 

May I ask, what is the 'AutogenModifier' - is it an application, or something that the scenery or APC is doing in the background because I don't find anything about it in the manual?

I have no problem with Third Party Scenery and ORBX. On my system it blends perfectly. I think a common mistake that people make is to have ORBX!OPENLC_EUROPE and ORBX!OPENLC_GLOBAL above their installed scenery. It should always be below everything just before the default FSX scenery begins. [That is in your scenery.cfg file]

 

Once again thank you for your continued support.

Regards

Terblanche

Share this post


Link to post
Share on other sites
vor 1 hour , yushpe sagte:

Hi, Kai! What has happened update? GSX has been running?

 

GSX works well now and autogen in airport surroundings is complete now.

 

Kai

Share this post


Link to post
Share on other sites

I cannot believe the great performance I get. Using free Prague scenery before this I get bad fps. The Aerosoft scenery has no fps hit for me. Like to see animated jetaways come soon.

Share this post


Link to post
Share on other sites

Just installed v1.02 and the problems still remain. There are no ILS's, no markings and in some cases no tarmac. Surely this product must have come out too soon. I have tried the 1.41 fix and nothing.

20160519114235_1.jpg

Share this post


Link to post
Share on other sites

Hi Premek,

 

what ist the changelog from 1.1 to 1.2

Is the Afcad changed or can we use the Version 1.4.1 from the Forum.

 

 

Frank

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...