Recently we have seen a lot of codes used to unlock our products being offered for discounted prices. Almost all of them are bought using stolen credit cards. These codes will all be blocked by our systems and you will have to try to get your money back from the seller, we are unable to assist in these matters. Do be very careful when you see a deal that is almost too good to be true, it probably is too good to be true.

Jump to content

Twin Otter Extended

Support for the Aerosoft Twin Otter Extended

922 topics in this forum

  1. Pinned topics
    • 144 replies
    • 19228 views
    • 141 replies
    • 14282 views
    • 37 replies
    • 13350 views
  2. Panels font issue

    • 23 replies
    • 4704 views
  3. Topics
    • 1870 replies
    • 389851 views
    • 255 replies
    • 38130 views
    • 161 replies
    • 31448 views
    • 153 replies
    • 33562 views
    • 61 replies
    • 11250 views
    • 61 replies
    • 7083 views
    • 60 replies
    • 7630 views
  4. Version 1.01 1 2

    • 44 replies
    • 7052 views
  5. Taxi power 1 2

    • 42 replies
    • 6450 views
    • 41 replies
    • 5616 views
    • 40 replies
    • 9711 views
    • 38 replies
    • 3355 views
  6. FF vs Prop changes 1 2

    • 37 replies
    • 3336 views
    • 37 replies
    • 8959 views
    • 34 replies
    • 5841 views
  7. Painter available 1 2

    • 34 replies
    • 5672 views
    • 32 replies
    • 2814 views
    • 32 replies
    • 3293 views
    • 30 replies
    • 6120 views
    • 26 replies
    • 4583 views
    • 26 replies
    • 6044 views
  • Posts

    • Flying over the Carribean from TKPK to KMIA and I ran over and into 5 weather systems, including on approach. I had rain on the windshield, but nothing every showed up on the weather radar.  This is the first time I have ever had this issue as it mornally works without issue.  Anyone else experience this after update? I have always used Active Skpy P3D v4 for the weather.
    • Okay, I just tested the Delta A319 (CFM) and I didn't have any issues with pressurization.   Maybe something didn't go right with the update?  If so, a reinstall might help.   Another question I have for you,  are you using the Copilot and/or Checklist (please let me know about either or both).  I made my flights without either the Copilot or Checklist, as these functions are primarily designed to indoctrinate those who are new to the Airbus on the procedures (though certainly they can be fun to use).   Looking forward to hearing back from you.  
    • Okay, thanks.  I'm doing a test flight right now int he A321 CFM, with no issues.  I'll take a look at the 319 CFM as well.  
    • It happened with the default 319 delta livery, so I believe that is cfm. It was last experimental version 1.2.4.1, not the just released. I followed all rebooting instructions.
    • Because we believe this topic has been answered we have closed it. If you have any more questions feel free to open a new topic.
×
×
  • Create New...