Archived

This topic is now archived and is closed to further replies.

Flight Freak

Problem beim Starten von x-plane

Recommended Posts

Wenn ich x plane starte,kommt eine x-system message, die sagt "There was a problem setting up OpenGL". Danach kommt eine Nachricht null texture=how? ref=102. Daraufhin stürtzt das Spiel ab.

Share this post


Link to post
Share on other sites

Die Meldung ist aber fast immer vorhanden, wenn ein OpenGL Treiber der Grafikkarte nicht passt. Das passierte z.B. ab und zu beim Wechsel auf Win 8.1. Und hier half ein Update der Grafikkarten Treiber für das Betriebssystem...

Falls der Treiber der Karte wirklich aktuell ist (für Win 7) , dann sind vielleicht die Grafikeinstellungen im X-Plane 10 zu hoch.

Dann müsste man die Preferences zurücksetzen und danach dann die Grafikeinstellungen wieder anpassen.

Beschrieben habe ich das hier:

http://forum.aerosoft.com/index.php?/topic/54451-kann-man-x-plane-10-auf-seine-standard-einstellungen-nach-der-installation-zurckfhren/

Aber wichtig ist auch die genaue X-Plane 10 Version, wie Rüdiger schon sagte.

Aktuell ist 10.22 Final oder 10.25 Beta 3.

Gruß

Share this post


Link to post
Share on other sites

Version von x-plane 10.22r2. Grafikeinstellungen habe ich heruntergesetzt, aber ohne Erfolg zu haben. X-plane Maker funktioniert auch nicht und die aktuelle Version vom Grafikkartentreiber lade ich grade herunter.

Share this post


Link to post
Share on other sites

@Flight Freak

poste hier doch bitte einmal den Inhalt der Datei 'Log.txt', die du im X-Plane-Verzeichnis findest. Vielleicht lassen sich hieraus Rückschlüsse auf etwaige Treiber-Probleme ziehen.

Ansonsten empfinde ich es immer als sehr angenehm, wenn man einen Artikel wenigstens mit seinem Vornamen unterschreibt, damit die anderen User wissen, mit wem sie es zu tun haben, falls sich dieser nicht aus dem Anmeldenamen ergibt. Hängt für mich etwas mit Höflichkeit zusammen. :D

Gruß,

Stephan

Share this post


Link to post
Share on other sites

  • Genaues betriebssystem: Windows7 Home Premium. Die Aktualisierung hat nichts gebracht. Danke schonmal.

Dann hört sich das nach einem erforderlichen Downgrade an, denn offensichtlich kommt OpenGL bei dir nicht hoch was eine Grundvoraussetzung für das starten von X-Plane ist. Ich vermute zu dem Zeitpunkt läuft X-Plane noch nicht wirklich.

Hast du vorher schon mal X-Plane 10 auf dem Rechner am Laufen gehabt?

Share this post


Link to post
Share on other sites

Moin, moin zusammen,

da klemmt es aber kräftig im Getriebe. Was meint Ihr, sollte man versuchen den kompletten Treiber samt NVidia-Software-Umgebung zu putzen?

Keinen Bammel, Flight Freak, ist nicht kompliziert, gibt es ein kleines Programm für:

http://www.chip.de/downloads/Driver-Cleaner-PE_13009243.html

Wichtig ist hinterher nur, das bei der Neuinstallation des NVidia-Treibers die benutzerdefinierte Installation ausgewählt wird, mit der Auswahl (Haken) "neu installieren", damit evtl. schiefe Konfigurationsdateien, die sich immer noch im System befindenden können, gelöscht werden.

Flight Freak, mach aber erst einmal nichts, erst mal hören, was die Fliegerfreunde meinen, die schon früher am Thema waren.

Besten Gruß

Dirk

Share this post


Link to post
Share on other sites

Die Daten kann ich leider erst heute Nachmittag schicken, da ich jetzt in die Schule muss. Aber es lief vorher schonmal richtig. (Mit niedrigen Einstellungen).

Gruß, Jan.

Share this post


Link to post
Share on other sites

Hallo Jan,

schön, das wir Dich nun auch mit Deinem wirklichen Namen ansprechen können.

Die Information, das es mit niedrigen Einstellungen schon einmal richtig lief, ist sehr wichtig.

Dann können wir uns das Gehunze mit der kompletten Treiberdeinstallation und Neueinrichtung der Grafikkarte, denk ich, schon einmal schenken.

Wichtig ist aber, das Du uns die log.txt von X-Plane, findest Du im X-Plane-Hauptverzeichnis, postest. Aus der können wir entnehmen, wann und an welcher Stelle X-Plane beim Start abnippelt.

Besten Gruß

Dirk

Share this post


Link to post
Share on other sites
log.txt for X-Plane 10.22r2 (64-bit build 102203) compiled on Jul 5 2013 11:17:00
This log file is generated automatically by Laminar Research applications and contains diagnostics about your graphics hardware, installation, and any error conditions.
If you need to contact tech support or file a bug, please send us this file. NOTE: this file is rewritten every time you start ANY of your X-System applications.
Windows 6.1 (build 7601/2) Service Pack 1
This is a 64-bit version of Windows.
CPU type: 8664
Physical Memory (total for computer): 8498311168
Maximum Virtual Memory (for X-Plane only): 8796092891136
CPU 0: Intel® Core i5-2410M CPU @ 2.30GHz Speed (mhz): 2294
CPU 0: Intel® Core i5-2410M CPU @ 2.30GHz Speed (mhz): 2294
CPU 0: Intel® Core i5-2410M CPU @ 2.30GHz Speed (mhz): 2294
CPU 0: Intel® Core i5-2410M CPU @ 2.30GHz Speed (mhz): 2294
WGL_EXT_depth_float WGL_ARB_buffer_region WGL_ARB_extensions_string WGL_ARB_make_current_read WGL_ARB_pixel_format WGL_ARB_pbuffer WGL_EXT_extensions_string WGL_EXT_swap_control WGL_ARB_multisample WGL_ARB_pixel_format_float WGL_ARB_framebuffer_sRGB WGL_ARB_create_context WGL_EXT_pixel_format_packed_float
OpenGL Vendor : Intel
OpenGL Render : Intel® HD Graphics Family
OpenGL Version : 3.1.0 - Build 8.15.10.2372 (310/0)
OpenGL Extensions: GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_EXT_texture_swizzle GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_EXT_texture_snorm GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_draw_elements_base_vertex GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_compatibility GL_ARB_vertex_array_object
threaded_avail : 1 dis_fog_avail : 0 instance_avail : 0 pbo_avail : 1
aniso_avail : 1 gshader_avail : 0 buniform_avail : 0 shad_lod_avail : 0
gpu_shad4_avail : 1 framebuf_avail : 1 frameblit_avail : 1 drawbuf2_avail : 1
tex_float_avail : 1 packed_stencil : 1 texture_rg : 1 framebuffer_srgb : 1
copy_buf_avail : 1 pinned_avail : 0 sync/fence : 1
max tex units : 8 (16/8)
max iso filtering: 16.000000
max texture size : 4096 (hardware limit)
max point size : 10.000000
idx in vram : 1
GLSL Version :1.40 - Intel Build 8.15.10.2372/140
first-gen shaders: 0
(16/512/41/16/16/1024/1024)
This video card is: DX10 - No instancing (found glMapBufferRange)
CPU count : 4
Could not set pixel format on worker DC: 87
0:00:00.000 E/SYS: +-------------------------------------------------------------------------------
0:00:00.000 E/SYS: | There was a problem setting up OpenGL.
0:00:00.000 E/SYS: | You can still fly, but you may experience pauses during flight while scenery loads.
0:00:00.000 E/SYS: |
0:00:00.000 E/SYS: | (Please send your log.txt file to Laminar Research for debugging purposes.)
0:00:00.000 E/SYS: | (OGL_extensions.cpp:1068)
0:00:00.000 E/SYS: +-------------------------------------------------------------------------------
0:00:00.000 E/SYS: +-------------------------------------------------------------------------------
0:00:00.000 E/SYS: | Null texture - how?
0:00:00.000 E/SYS: |
0:00:00.000 E/SYS: | ref= 1021
0:00:00.000 E/SYS: |
0:00:00.000 E/SYS: | (tman.cpp:235)
0:00:00.000 E/SYS: +-------------------------------------------------------------------------------
----- X-Plane has shut down -----

Share this post


Link to post
Share on other sites

Hallo, das sieht nach Laptop mit 2 Grafik Systemen aus.

Intel HD Grafiks (für X-Plane ganz schlecht) und eine NVidia 525M (die Du ja im Post 3 angegeben hast).

Wenn man keine Angaben im System macht, dann verwendet der PC warscheinlich, wie auch im Log angezeigt nur die HD Grafik.

In der Nvidia Systemsteuerung kannst Du explizit für X-Plane 10 erzwingen, dass für X-Plane die Nvidia genommen wird.

Gruß

Share this post


Link to post
Share on other sites

Jups Heinz,

wenn nicht über die NVidia-Systemsteuerung, dann doch bestimmt über das BIOS.

Die Intel HD als primäre Grafikkarte zu fahren macht für mich nur Sinn, wenn das Laptop zur meisten Zeit mobil, ohne Stromnetzzugang gefahren wird.

Besten Gruß

Dirk

Share this post


Link to post
Share on other sites

Danke, da ich aber leider nicht sonderlich belaufen bin, was Computer angeht, wollte ich fragen, wie man das in der Nividia Systemsteuerung erzwingen kann, dass diese in x-plane genommen wird.

Gruß

Jan

Share this post


Link to post
Share on other sites

Ich besitze einen ähnlichen Laptop mit zwei Grafiksystemen (auch eine GeForceM).

Du müsstest unter Windows eigentlich schlicht mit einem Rechtsklick (einfach auf den Desktophintergrund) manuell zwischen den Grafikkarten hin- und herschalten können. Meist heißt es dort "auf Leistungsstarke GPU umschalten" oder "Grafik umschalten", "GPU wählen"...

Das Bild wird für einen kurzen Augenblick schwarz und sieht danach aus wie zuvor. Jedoch ist nun die andere Karte aktiv und du kannst X-Plane starten.

Dies müsstest du einfach vor jedem X-Plane start manuell durchführen.

Philip

Share this post


Link to post
Share on other sites

Hallo Jan,

die Nvidia Systemsteuerung findes Du in der Windows Systemsteuerung.

Einfach aufmachen.

Dort gibt es eine Funktion 3D-Einstellungen verwalten.

Und dort kann man den "bevorzugten" Grafikprozessor einstellen.

Entweder Global, das gilt dann immer, oder für bestimmte Programme.

Dort könnte man dann die entsprechende X-Plane.exe auswählen.

Gruß

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.