Sign in to follow this  
Followers 0

Re-Installation von Switzerland Professional

22 posts in this topic

# 1   Posted · Report post

Wegen ständiger Abstürze des FSX sah ich mich letzte Woche gezwungen den FSX mit allen Addons zu deinstallieren. Wie zu befürchten gab es einige Schwierigkeiten die ich durch Zusatzsoftware lösen konnte. Danach war die Festplatte laut Systemsteuerung, Zusatzsoftware und Dateiexplorer frei von allen Dateien und soweit erkennbar Fragmenten. Die Neuinstallation des FSX lief bis heute abend auch problemlos, bis auf eine Ausnahme: Switzerland Professional lässt sich mit der (hier frei aus dem Englischen übersetzten) Fehlermeldung: "Programm bereits installiert, bitte erst deinstallieren bevor sie die Software erneut installieren" nicht mehr installieren. Und das ist jetzt mein Problem - ich habe keine Ahnung, wo/wie ich jetzt noch deinstallieren soll. Meines Erachtens ist alles deinstalliert, nirgendwo finde ich auch nur den geringsten Eintrag.

Alle anderen Addons, incl. der kompletten VFR-Germany-Reihe ließen sich bis jetzt problemfrei installieren. Ich brauche hier dringend Hilfe, bitte!!

Harald

0

Share this post


Link to post
Share on other sites

# 2   Posted · Report post

Hallo Harald,

such bitte mal in der Registry nach deiner Switzerland installation, kann sein das die Installation dort nicht gelöscht ist und dann auch nicht erneut installiert weden kann, das geht so: in der Taskleiste Start anklicken, Ausführen "regedit" eingeben, in suchen den Ordnernahmen deiner Switzerland installation eingeben und alles was mit Switzerland zu tun hat löschen, darauf achten das bei der suche mit Arbeitsplatz angefangen wird.

Mit freundlichen Grüssen

Erwin

0

Share this post


Link to post
Share on other sites

# 3   Posted · Report post

Hallo Erwin,

danke für den Tipp. Ich hab mal nachgeschaut. Unter dem Suchbegriff "Switzerland" findet das Programm "regedit" noch 4 Einträge, alle mit dem Typ "REG_SZ". Soll ich alle 4 wirklich löschen? Kann ich damit am FSX was kaputt machen?

Harald

0

Share this post


Link to post
Share on other sites

# 4   Posted · Report post

Hallo Erwin,

danke für den Tipp. Ich hab mal nachgeschaut. Unter dem Suchbegriff "Switzerland" findet das Programm "regedit" noch 4 Einträge, alle mit dem Typ "REG_SZ". Soll ich alle 4 wirklich löschen? Kann ich damit am FSX was kaputt machen?

Harald

Hallo Harald,

der Eintrag Switzerland bezieht sich nur auf dein nicht mehr vorhandenes Schweitz- Add-On, am FS X kannst du mit der Löschung keinen Schaden anrichten. Anmerkung: Du hast die Suche doch bis zum Ende der Registry durchgeführt, bei erneuter Schweiz installation werden die Einträge in der Registy erneuert, wenn nicht schon ausgeführt solltest Du auch alle deine Partitionen nach deiner Schweiz installation durchsuchen und gegebenfalls löschen, vorsicht falls dein Schweiz Add-On eine Download Version ist, die natürlich nicht löschen.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 5   Posted · Report post

Hallo Erwin,

habe gerade versucht alle 4 Dateien zu löschen. Bei 3 hat's geklappt, die 4. (Name: Standard; Typ: REG_SZ; Wert: (Wert nicht gesetzt) hat's nicht geklappt. Die Installation geht, wahrscheinlich wegen des einen Fragments noch immer nicht. Zur Frage ob ich die Suche bis zum Ende der Registry durchgeführt habe: Im Registrierungseditor habe ich im linken Feld den Pfad "Computer" angeklickt und dann über die Menüzeile nach dem Suchbegriff "Switzerland" gesucht. Dabei kamen die 4 Dateien raus. Ich glaube damit habe ich alles durchgesucht. Wenn ich übrigens die Suche mit "germany" durchführe bekomme ich weitere, vorher nicht angezeigte Dateien die ich aber auch nicht löschen kann. Wie kann ich die sonst noch löschen? Die Fehlermeldung lautet: "Nicht alle angegebenen Werte können gelöscht werden".

Harald

0

Share this post


Link to post
Share on other sites

# 6   Posted · Report post

Hallo Erwin,

habe gerade versucht alle 4 Dateien zu löschen. Bei 3 hat's geklappt, die 4. (Name: Standard; Typ: REG_SZ; Wert: (Wert nicht gesetzt) hat's nicht geklappt. Die Installation geht, wahrscheinlich wegen des einen Fragments noch immer nicht. Zur Frage ob ich die Suche bis zum Ende der Registry durchgeführt habe: Im Registrierungseditor habe ich im linken Feld den Pfad "Computer" angeklickt und dann über die Menüzeile nach dem Suchbegriff "Switzerland" gesucht. Dabei kamen die 4 Dateien raus. Ich glaube damit habe ich alles durchgesucht. Wenn ich übrigens die Suche mit "germany" durchführe bekomme ich weitere, vorher nicht angezeigte Dateien die ich aber auch nicht löschen kann. Wie kann ich die sonst noch löschen? Die Fehlermeldung lautet: "Nicht alle angegebenen Werte können gelöscht werden".

Harald

Harald,

was hast Du den für ein Betriebssystem auf deinem Computer, bei meinem BS,"Windows XP x64" fängt die Suche in der Regstry mit Arbeitsplatz an.

Hast Du den bei der Suche mit dem Begriff "germany" was gefunden, das mit deiner Switzerland installation zu tun hat, was mich wundern würde.

Als Vorschlag hätte ich noch, den Rechner runter fahren, wieder starten, die Registry erneut durchsuchen und gefundene Einträge, versuchen erneut zu löschen. Wenn Löschung erfolgreich, Rechner erneut runter fahren und Schweiz Add-On erneute installation versuchen.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 7   Posted · Report post

Hallo Erwin,

ich habe Vista Home Premium installiert. Vielleicht hilft ja ein Screenshot von meinem Registrierungs-Editor (http://i253.photobuc...ungs-Editor.jpg)? Das mit dem Runter- und Wiederhochfahren habe ich mir auch schon überlegt. Manchmal hilft das wirklich. Für heute muß ich jetzt aber Schluß machen da ich morgen wieder fit sein muß in der Arbeit. Ich hoffe, du kannst mir morgen wieder weiterhelfen,

tschüss!

0

Share this post


Link to post
Share on other sites

# 8   Posted · Report post

Hallo Erwin,

ich habe Vista Home Premium installiert. Vielleicht hilft ja ein Screenshot von meinem Registrierungs-Editor (http://i253.photobuc...ungs-Editor.jpg)? Das mit dem Runter- und Wiederhochfahren habe ich mir auch schon überlegt. Manchmal hilft das wirklich. Für heute muß ich jetzt aber Schluß machen da ich morgen wieder fit sein muß in der Arbeit. Ich hoffe, du kannst mir morgen wieder weiterhelfen,

tschüss!

Hallo Harald,

Du kannst auch mal mit der Vista Ordner und Dateien Suchfunktion nach den Scenery.cfg Dateien auf deinen Partitionen suchen und in den Scenery.cfg Dateien nach Einträgen von deiner Schweiz installation suchen und gegebenen falls löschen. Mit dem Screenshot von deiner Registry konnte ich nichts anfangen war kaum etwas zu erkennen.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 9   Posted · Report post

Guten Abend Erwin,

sorry dass es solange gedauert hat, bin wirklich nicht früher an die Maschine gekommen. Ich habe inzwischen die Suchfunktion im Vista-Explorer bemüht und etliche Scenery.cfg gefunden - keine davon hatte einen Eintrag über Switzerland Prof.

Ich habe daraufhin noch einmal in der regedit nachgeschaut und wie gestern wieder die Datei die ich nicht löschen konnte gefunden. Dabei fiel mir ein, dass ich ja nicht zwingend die Datei sondern vielleicht sogar den Ordner löschen sollte / könnte (die Hoffnung stirbt zuletzt). Leider hat's letztendlich nichts gebracht. In der regedit finde ich jetzt definitiv nichts mehr mit dem Suchbegriff Switzerland. Die Installation von der DVD verweigert sich aber noch immer mit dem Hinweis dass die Software angeblich schon installiert sei.

Bei der Neuinstallation des FSX habe ich inzwischen alle Programme die ich auf DVD's hatte (21 Stück!) installiert. Davon ist heute eine weitere Aersoft-DVD mit dem gleichen Fehler aufgetreten, German Airfields 1 (Inselhüpfen). Ich habe auch hier in der regedit einen entsprechenden Ordner-Eintrag gefunden, gelöscht und gehofft dass die Installation starten würde - ebenfalls negativ.

Schon gestern hast du empfohlen, ich soll den Rechner neu starten. Leider bin ich noch nicht dazugekommen da ich ständig nachinstalliere (schön brav nach jeder Neuinstallation FSX starten, checken ob sich alles anmeldet) und nach einigen Gigabytes auch immer wieder defragmenieren damit es nicht zu allzu groben Zerstückelungen der Festplatte kommt. Aktuell läuft jetzt eine Defragmentierung, die wird sicher noch ein, zwei Stunden dauern. Ob ich dann noch heute zum Check komme weiß ich nicht, spätestens morgen aber bin ich so weit.

Blöd (oder gut??) ist "nur" dass von den vielen DVD's die ich nachinstalliert habe nur die 2 Programme streiken. Hoffentlich kriege ich die wieder zum laufen.

Ich melde mich nach dem Neustart und den darauf durchgeführten Installationsversuchen. Bis dahin vorerst mal vielen Dank für die Hilfe. Ich hatte bis jetzt nur einen blassen Schimmer davon welche Monsterdateien und welche Ordnerflut im FSX versteckt sind.

Harald

0

Share this post


Link to post
Share on other sites

# 10   Posted · Report post

Harald,

probiere doch mal folgendes: Unter Vista/Benutzer(Dein Name)/AppData/Local/Temp den Inhalt zBsp. auf einen Stick kopieren und dann den eigentlichen Inhalt auf der festplatte löschen. Danach nochmals versuchen Switzerland zu installieren. Sollte das klappen, danach die Daten vom Stick wieder zurück verschieben in den Ausgangsordner.

Gruß Andreas

0

Share this post


Link to post
Share on other sites

# 11   Posted · Report post

Guten Abend Erwin,

sorry dass es solange gedauert hat, bin wirklich nicht früher an die Maschine gekommen. Ich habe inzwischen die Suchfunktion im Vista-Explorer bemüht und etliche Scenery.cfg gefunden - keine davon hatte einen Eintrag über Switzerland Prof.

Ich habe daraufhin noch einmal in der regedit nachgeschaut und wie gestern wieder die Datei die ich nicht löschen konnte gefunden. Dabei fiel mir ein, dass ich ja nicht zwingend die Datei sondern vielleicht sogar den Ordner löschen sollte / könnte (die Hoffnung stirbt zuletzt). Leider hat's letztendlich nichts gebracht. In der regedit finde ich jetzt definitiv nichts mehr mit dem Suchbegriff Switzerland. Die Installation von der DVD verweigert sich aber noch immer mit dem Hinweis dass die Software angeblich schon installiert sei.

Bei der Neuinstallation des FSX habe ich inzwischen alle Programme die ich auf DVD's hatte (21 Stück!) installiert. Davon ist heute eine weitere Aersoft-DVD mit dem gleichen Fehler aufgetreten, German Airfields 1 (Inselhüpfen). Ich habe auch hier in der regedit einen entsprechenden Ordner-Eintrag gefunden, gelöscht und gehofft dass die Installation starten würde - ebenfalls negativ.

Schon gestern hast du empfohlen, ich soll den Rechner neu starten. Leider bin ich noch nicht dazugekommen da ich ständig nachinstalliere (schön brav nach jeder Neuinstallation FSX starten, checken ob sich alles anmeldet) und nach einigen Gigabytes auch immer wieder defragmenieren damit es nicht zu allzu groben Zerstückelungen der Festplatte kommt. Aktuell läuft jetzt eine Defragmentierung, die wird sicher noch ein, zwei Stunden dauern. Ob ich dann noch heute zum Check komme weiß ich nicht, spätestens morgen aber bin ich so weit.

Blöd (oder gut??) ist "nur" dass von den vielen DVD's die ich nachinstalliert habe nur die 2 Programme streiken. Hoffentlich kriege ich die wieder zum laufen.

Ich melde mich nach dem Neustart und den darauf durchgeführten Installationsversuchen. Bis dahin vorerst mal vielen Dank für die Hilfe. Ich hatte bis jetzt nur einen blassen Schimmer davon welche Monsterdateien und welche Ordnerflut im FSX versteckt sind.

Harald

Hallo Harald,

die beiden Add-Ons sind doch sicher mit einer Installations EXE-Datei installiert worden, z.b Switzerland-Prof.exe oder so ähnlich, such doch bitte mal nach solchen Dateien, ich selber kenne die Add-Ons nicht, bin also nicht darüber informiert wie die Install.-Datei heisst.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 12   Posted · Report post

Hallo Erwin, Andreas,

habe soeben beide Tipps probiert, leider kein Erfolg. Ich kriege immer die Fehlermeldung "Software bereits installiert". Noch irgendwelche Ideen? Lesen hier im Forum auch Aerosoft-Mitarbeiter mit? Irgendwie muß das doch zu lösen sein? Ich bleibe heute noch etwas online, ansonst bin ich morgen abend wieder vor der Kiste,

Harald

0

Share this post


Link to post
Share on other sites

# 13   Posted · Report post

Hallo Erwin, Andreas,

habe soeben beide Tipps probiert, leider kein Erfolg. Ich kriege immer die Fehlermeldung "Software bereits installiert". Noch irgendwelche Ideen? Lesen hier im Forum auch Aerosoft-Mitarbeiter mit? Irgendwie muß das doch zu lösen sein? Ich bleibe heute noch etwas online, ansonst bin ich morgen abend wieder vor der Kiste,

Harald

Hallo Harald,

ich könnte Dir ein Tool zum aufräumen der Registry schicken, das Tool entfernt auch verweiste Einträge aus der Registry, das sind Einträge, die zu keinem Programm mehr zugeordnet sind aber unter Umständen eine Neuinstallation einer Anwendung verhindern.

Das Tool heisst: "TweakNow RegCleaner", oder Du kannst es dir auch selber aus dem Internet runterladen, ich habe es von Chip Online, oder den Namen des Tools bei Google eingeben.

Wenn Du es von mir geschickt haben möchtest, eine kurze Nachricht reicht.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 14   Posted · Report post

Hallo Harald,

eine Möglichkeit gibt es noch wo sich deine Schweiz Installation eingetragen haben könnte, jedenfalls bei Win XP ist das so, auf deiner Betriebssystem Partition für den FS X, könnte es einen versteckten Ordner geben, in den alle Installationen eingetragen werden.

Bei Win XP heisst der Ordner: "InstallShield Installation Information".

Versteckte Ordner kann man sichtbar machen im Dateimanager, Ordner Optionen, Ansicht, versteckte Dateien und Ordner, suchen und Anzeigen markieren.

Dann den InstallShield Ordner öffnen dort könntest Du so ähnliche Dateien finden:

{1D67FB28-58DA-4425-B426-99E894468197}

Datei öffnen und die Setup.ini öffnen, dann sollte in der ini stehen welche Installation das ist.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 15   Posted · Report post

Das ist eine gute Idee, Erwin. Ich kann leider die GUID nicht selbst herausfinden und der passende Kollege ist leider krank, aber ich hoffe, dass wir da bald helfen können. Zur Not tatsächlich mal alle INIs durchsuchen.

0

Share this post


Link to post
Share on other sites

# 16   Posted · Report post

Hallo Erwin,

VOLLTREFFER!!!! Klasse Idee mit dem InstallShield Ordner. Da waren tatsächlich die Installer noch drin. Sowohl vom German Airfields 1 als auch von Switzerland Professional. Inzwischen habe ich die Airfields schon wieder installiert (kurzer Probeflug von Borkum hat geklappt) , die Installation der Schweiz läuft gerade.

Vielen Dank für die Super Hilfe. Ohne Dich und Andreas hätte ich das nie hingekriegt. Ich hatte / habe noch immer keine Ahnung wie Computer arbeiten. Ich gehe mal davon aus, dass die Installation reibungslos abläuft. Wenn alles abgeschlossen ist und im FSX auch läuft melde ich mich zum Abschluß noch mal kurz. Ich muß jetzt aber noch mal kurz in die Firma wegen einer Schulung - danach kann ich vielleicht die Meldung schon liefern.

Harald

0

Share this post


Link to post
Share on other sites

# 17   Posted · Report post

Hallo Erwin,

VOLLTREFFER!!!! Klasse Idee mit dem InstallShield Ordner. Da waren tatsächlich die Installer noch drin. Sowohl vom German Airfields 1 als auch von Switzerland Professional. Inzwischen habe ich die Airfields schon wieder installiert (kurzer Probeflug von Borkum hat geklappt) , die Installation der Schweiz läuft gerade.

Vielen Dank für die Super Hilfe. Ohne Dich und Andreas hätte ich das nie hingekriegt. Ich hatte / habe noch immer keine Ahnung wie Computer arbeiten. Ich gehe mal davon aus, dass die Installation reibungslos abläuft. Wenn alles abgeschlossen ist und im FSX auch läuft melde ich mich zum Abschluß noch mal kurz. Ich muß jetzt aber noch mal kurz in die Firma wegen einer Schulung - danach kann ich vielleicht die Meldung schon liefern.

Harald

Hallo Harald,

freut mich das die Flusiwelt bei Dir anscheinend wieder in Ordnung kommt, zu deinem Problem mit Switzerland und German Airfields 1 habe ich jetzt eine Frage, wie hast Du die beiden Add-Ons De-Installiert, bevor Du den FS X erneut installiert hast.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 18   Posted · Report post

Hallo Erwin,

ich bin wieder zurück. Switzerland läuft im FSX (Probeflug ab Emmen Richtung Luzern). Ich werde jetzt wieder defragmentieren und dann nächste Woche die restlichen Download-Addons (v.a. Flugzeuge) installieren.

Zur Deinstallation: Ich habe alle Programme über die Vista-Systemsteuerung deinstalliert (Verzeichnis Programme / Programme deinstallieren). Ich habe bei einem früheren Versuch einmal einige Addons über das integrierte Deinstallationsprogramm gelöscht, gab aber auch Probleme und vor allem haben viele Addons nicht diese Deinstallationsmöglichkeit. Deswegen diesesmal über die Systemsteuerung. Danach habe ich mit der Software Advanced Deinstaller (Freeware) noch mal gegengecheckt und mußte feststellen dass noch einige "Überbleibsel" vorhanden waren. Die habe ich dann auch noch gleich gelöscht. Erst dann habe ich den FSX, die SP1 und SP2 usw. usw. installiert. Und bis auf diese 2 Programme hat es ja auch bei allen geklappt - und ich habe wirklich viel Zusatzsoftware, auch viel von Aerosoft.

Ich werde mir aber noch mal das von dir angesprochene Tool "TweakNow RegCleaner" anschauen. Vielleicht ist das besser als meines. Aber bitte gestatte mir eine Gegenfrage: Was ist denn deiner Meinung nach die beste Lösung zur Deinstallation von solchen Programmen?

mfg Harald

0

Share this post


Link to post
Share on other sites

# 19   Posted · Report post

Harald ,

ich benutze den CCleaner. Der bereinigt Dir auch soweit alles und ist einer der Top10 Freeware Programme. Zudem in Deutsch und selbsterklärend. Hinzu wird er regelmäßig upgedatet.

Dabei ist eine Funktion zum Deinstallieren. Die löscht das Programm über die Deinstallerfunktion und zusätzlich scannt sie das System noch nach verbliebenen Dateien des Programmes. Regelmäßig den PC gewartet, dann haste weniger Probleme.

Gruß und Guten Flug durch die Schweiz wünscht Andreas

0

Share this post


Link to post
Share on other sites

# 20   Posted · Report post

Harald ,

ich benutze den CCleaner. Der bereinigt Dir auch soweit alles und ist einer der Top10 Freeware Programme. Zudem in Deutsch und selbsterklärend. Hinzu wird er regelmäßig upgedatet.

Dabei ist eine Funktion zum Deinstallieren. Die löscht das Programm über die Deinstallerfunktion und zusätzlich scannt sie das System noch nach verbliebenen Dateien des Programmes. Regelmäßig den PC gewartet, dann haste weniger Probleme.

Gruß und Guten Flug durch die Schweiz wünscht Andreas

Danke für die Info. Ich hab zwar schon vom CCleaner gehört wußte ihn aber nicht einzuschätzen. Ich schau ihn mir auf alle Fälle mal an. Und noch mal vielen Dank für deine Tipps!

Harald

0

Share this post


Link to post
Share on other sites

# 21   Posted · Report post

Hallo Erwin,

ich bin wieder zurück. Switzerland läuft im FSX (Probeflug ab Emmen Richtung Luzern). Ich werde jetzt wieder defragmentieren und dann nächste Woche die restlichen Download-Addons (v.a. Flugzeuge) installieren.

Zur Deinstallation: Ich habe alle Programme über die Vista-Systemsteuerung deinstalliert (Verzeichnis Programme / Programme deinstallieren). Ich habe bei einem früheren Versuch einmal einige Addons über das integrierte Deinstallationsprogramm gelöscht, gab aber auch Probleme und vor allem haben viele Addons nicht diese Deinstallationsmöglichkeit. Deswegen diesesmal über die Systemsteuerung. Danach habe ich mit der Software Advanced Deinstaller (Freeware) noch mal gegengecheckt und mußte feststellen dass noch einige "Überbleibsel" vorhanden waren. Die habe ich dann auch noch gleich gelöscht. Erst dann habe ich den FSX, die SP1 und SP2 usw. usw. installiert. Und bis auf diese 2 Programme hat es ja auch bei allen geklappt - und ich habe wirklich viel Zusatzsoftware, auch viel von Aerosoft.

Ich werde mir aber noch mal das von dir angesprochene Tool "TweakNow RegCleaner" anschauen. Vielleicht ist das besser als meines. Aber bitte gestatte mir eine Gegenfrage: Was ist denn deiner Meinung nach die beste Lösung zur Deinstallation von solchen Programmen?

mfg Harald

Harald,

so wie Du die De-Installation der Add-Ons durchgeführt hast ist das schon in Ordnung, eine andere Möglichkeit hat man ja kaum, da hat wohl die De-Installationsroutine von Vista nicht richtig gearbeitet, den bei der De-Installation sollen auch die Einträge im InstallShield-Ordner gelöscht werden, sonst gibt es, wie ja jetzt bekannt Probleme bei einer Neuinstallation.

Meine Vermutung war das Du die Add-Ons nicht De-Installiert hast sonder nur einfach gelöscht, in so einem Fall bleiben auch die Einträge in dem InstallShield-Ordner erhalten.

Mit dem von mir genannten Tool "TweakNow RegCleaner" kann man nur die Registry bearbeiten, keine Anwendungen de-installieren.

Aber jetzt ist ja wieder alles palleti, ich wünsche gutes gelingen, viel spass mit dem FS X und immer glückliche Landung.

Mfg.

Erwin

0

Share this post


Link to post
Share on other sites

# 22   Posted · Report post

Vielen Dank, Erwin! Ich hatte dasselbe Problem, CHproX nicht erneut installieren zu können. Dank "InstallShield Installation Information" (auch bei Win7 64 im Programme(x86)-Verzeichnis) habe ich nun den Installer wieder ans Laufen gekriegt. Dort hätte ich ja nie gesucht...

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0