Sign in to follow this  
Followers 0

FSX Acceleration activation

5 posts in this topic

# 1   Posted

Hey guys.

I had to reinstall the whole FSX again, because I had some problems installing new addons (PMDG 744, fsdt LSGG ..) as my dll.xml seemed to be corrupted (unfortunately I don't know neither which addons use this file, nor which one caused the problems). Anybody had this too? So first I uninstalled all my addons, then Acceleration (using W7 uninstaller in the control panel) and finally put in the FSX disk to uninstall the sim itself. I deleted what remained in the Microsoft Games/Microsoft Flight Simulator X folder (about 4 folders like SimObjects).

Now I tried to reinstall FSX, SP1, SDK, SDK1a and Acceleration. Then I tried to start the flightsim and received an error message telling me that there would be a problem with the activation of the product. Google showed me the following solution:

http://support.microsoft.com/kb/927007

1. In Windows XP, click Start, click Run, type regedit, and then OK.

In Windows Vista, click Startthe Start button, type regedit in the Start Search box, and then click regedit.exe in the Programs list.

User Access Control permission If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

2. Expand the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\CLASS\{4D36E967-E325-11CE-BFC1-08002BE10318}

3. After you find the folder, double-click Upperfilters on the right side.

4. Change the value from 0 to PartMgr, and then click OK. (mine said CLEANBOOT on one line and partmgr on the next, just remove one line leaving PartMgr as the value)

5. Close Registry Editor, and then try to use the activation wizard.

Anyone tried this already?

Best regards

0

Share this post


Link to post
Share on other sites

# 2   Posted

And, did it work? Were you able to activate?

I must say that you have done a number of things incorrectly here. After a complete uninstall you really should clean out the registry with something like CCleaner and get rid of the masses of FSX related entries which the uninstallers fail to remove. Then, there is a specific way of installing FSX as follows:

1. Install FSX from the DVD, load up the sim and load up the default flight

2. Exit the sim and reboot.

3. Install Acceleration from the DVD, again load up the sim and load up the default flight.

4. Exit the sim and reboot.

Folks often balk at this install procedure but you do not follow it at the very real risk of ending up with a poorly performing FSX install. It has been documented countless times. Not sure why you are installing the SDK? And for sure you do not need SP1 if you are installing Acceleration (which includes SP1 and SP2).

From your post it seems that you are installing FSX on your C drive (i.e. the VRaptor 300GB) in the default location? Is this correct? You really should be installing FSX on your second drive (the Spinpoint) in a folder simply called FSX. FS9 should be on the same drive in a folder called FS9.

1

Share this post


Link to post
Share on other sites

# 3   Posted

And, did it work? Were you able to activate?

I must say that you have done a number of things incorrectly here. After a complete uninstall you really should clean out the registry with something like CCleaner and get rid of the masses of FSX related entries which the uninstallers fail to remove. Then, there is a specific way of installing FSX as follows:

1. Install FSX from the DVD, load up the sim and load up the default flight

2. Exit the sim and reboot.

3. Install Acceleration from the DVD, again load up the sim and load up the default flight.

4. Exit the sim and reboot.

Folks often balk at this install procedure but you do not follow it at the very real risk of ending up with a poorly performing FSX install. It has been documented countless times. Not sure why you are installing the SDK? And for sure you do not need SP1 if you are installing Acceleration (which includes SP1 and SP2).

From your post it seems that you are installing FSX on your C drive (i.e. the VRaptor 300GB) in the default location? Is this correct? You really should be installing FSX on your second drive (the Spinpoint) in a folder simply called FSX. FS9 should be on the same drive in a folder called FS9.

Good evening Konrad.

Didn't test it so far.

Well, I didn't ever use a program like CCleaner, but I will try this on Sunday.

I installed the sim as you described it with the default flights except that I installed SP1, which should not be a problem as the addon has been released several month later than SP1 (so I think it just overwrites SP1). I just installed the SDK because it is on the disk too, not really an explanation I know ;)

I have my Windows on drive C: on the SpinPoint. Both simulators are on drive E: which is the Velociraptor.

I will report the current status this weekend.

Thanks for your help Konrad.

0

Share this post


Link to post
Share on other sites

# 4   Posted

Hello Guys,

This link here of any use.

Hans H had the same issue and I found the thread above, Hans tried it and a bit of registry editing resolved the issue for him as per the threads instructions.

1

Share this post


Link to post
Share on other sites

# 5   Posted

Good evening guys.

I uninstalled everything related to my FSX and then used the CCleaner. After having installed FSX again, tha only result I could see (well, it wasn't really a result but the only change I could recognize) was that my mouse cursor was black. Then I installed Acceleration and was unable to activate it. So I changes my registry entries to "PartMgr" and everything was fine (even the cursor ;) ) and I could activate and use my FSXacc. Thanks guys!

(I didn't change the registry back to the initial value. Mine was something like "PartMgr snapman", but it works anyway).

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0