Recommended Posts

I have a P3Dv4.3 machine and have the CRJ 700/900 v 1.0.5.0 loaded. Just started flying the little girl. Steadily getting there. 

When I save the flight and reload that flight following a reboot a few hours later, I lose the FMS info. The flight setup seems ok, and in for a wild ride on startup, and then starts to return to its previous level.

 

I fire up P3D, always load the default F22 and the airport. With the default sitting on the runway, I then use the P3D Scenario>Load>(find the saved flight, it has a .fxml ext) click OK . When loaded, I can see the aircraft is at the correct flight level, and on my littlenavmap and it is in the correct position. We go into a extreme climb with the previous alt flashing, With no flight plan loaded, we are not going anywhere....

What am I missing on the save/reload to get my saved flight working.

Share this post


Link to post
Share on other sites

This is one of the issues that were fixed with Service Pack 1. Please download the new installer from your shop account.

Share this post


Link to post
Share on other sites
17 hours ago, Hans Hartmann said:

This is one of the issues that were fixed with Service Pack 1. Please download the new installer from your shop account.

Hi Hans, I did two changes before I retested the flight plan scenario load. 

 

Updated the CRJ700/900 to 1.2.0.0. Set up a flight from KORD to KMEM and as I was climbing out and at 20,000+ feet, I got a CABIN ALT and PASS OXY ON warning...so, a bit of searching in the Aerosoft Forum, and I found there was an update for this issue on the updater-experimental. carried out the update.

 

Before I created the test flight, I loaded the default a/c and the default airport as usual, then thought, ummm, I have a few saved flights with the CRJ700, load one to save me having to rebuild the flight plan and aircraft config etc now that I have the SP1 build....NAH....Every load of saved scenario's crashed P3D. Maybe P3D sees the saved scenario's from a different version of the CRJ700 as different builds and not happy to load them?

Ok, Observations about the flight.

 

The flight I created is now passing through 32000 and no CABIN ALT and PASS OXY ON warning. Great. Fixed.

I saved the flight at cruising. Then closed P3D. Rebooted P3D, loaded the default a/c and airport. Used the P3D Scenario tab and loaded the saved flight. It loaded pretty good with all engines and settings the same.The Flight plan was in place and active. I did have one issue. On the PFD, the next waypoint is flashing and a bipping sound. 

 

Why is it some times setting up the flight plan and cockpit settings, on the PFD, under the V speeds, the first waypoint is flashing all the time, in my case, 34.0NM CMSKY. When I pass that waypoint, it stops flashing when the new waypoint to come is displayed. Subsequent waypoints do not flash. I notice when I select other than FMS1/2 the flashing stops, but I lose the Nav control for the flight plan.  

Share this post


Link to post
Share on other sites

OK, next step is to run the Aerosoft Updater and update the CRJ to the latest version (which fixes the pressurization issue). I should have said that in my last post. Sorry.  

Share this post


Link to post
Share on other sites
1 hour ago, Hans Hartmann said:

OK, next step is to run the Aerosoft Updater and update the CRJ to the latest version (which fixes the pressurization issue). I should have said that in my last post. Sorry.  

Hi Hans,

Sorry, I must have explained myself wrongly. The fix you recommended in your first post worked.

 

I did update the a/c to SP1 and I did use the updater to add the repair for the CABIN ALT and PASS OXY warning.

 

The Save and Reload the Flight Scenario now works, with one issue. When I reloaded the Flight Scenario, On the PFD, the next waypoint is flashing and a bipping sound. I have seen this before. Why is it some times setting up the flight plan and cockpit settings, on the PFD, under the V speeds, the first waypoint is flashing all the time, in my case, 34.0NM CMSKY. When I pass that waypoint, it stops flashing when the new waypoint to come is displayed. Subsequent waypoints do not flash. I notice when I select other than FMS1/2 the flashing stops, but I lose the Nav control for the flight plan.    

 

The  CABIN ALT and PASS OXY ON warning no longer appears. so this is fixed.

 

 

 

 

Share this post


Link to post
Share on other sites

As stated previously, I Updated the CRJ700/900 to 1.2.0.0. and applied the Updater for the CABIN ALT and PASS OXY ON warning. On the same day, with no P3D restart, when I saved a flight and reloaded it, the scenario was correctly loaded. and I could carry on with the flight.

However, after a restart of my P3D machine, and I reload P3D and try and load the same saved flight, it crashes P3D...either straight to the screen saver or it might hang unresponsive and needs me to use Task Manager and end task.

 

Anyway.........Later, I will create a flight plan and configure the CRJ900 again for taxi, sitting at an airport. Save it, and while P3D still running, reload it. Assuming it loads ok, I will then reboot the P3D machine and retry loading the scenario and see what happens and report back. I have been playing with the Updater, so I am not sure if this has upset it.

My method of reloading a scenario is to:

Load P3D>at the load screen, accept the default a/c(F22) which has its engines running, and accept the default airport, select ok, and when the F22 is sitting at the end of the default runway, I select Scenario from the top left, and select load. Chose the saved flight scenario, click ok. 

 

Maybe my machine is sensitive to this reload action. I recently had the P3D QW 787...For me, the major issue was being unable to get the saved flight scenario to reload. Apparently some QW 787 people did not have any issues. There was another group of us that did have this issue. 

Share this post


Link to post
Share on other sites

OK, when I created and saved the scenario, then tried to reload it, it crashed P3D. Several attempts all had the same outcome. Sometimes to the screen saver some times the load hangs requiring me to crash out.

For some reason, despite the two updates, that previously allowed me to load a saved scenario, have now stopped working.

All other aspects of the aircraft seem to work great.

 

When I reload a saved scenario for the A318-A321, I have no issues. The same for the FSL A320, the PMDG 777, the majestic Q400..all load ok.  

Share this post


Link to post
Share on other sites

Same for me in V4 and V3 after several installation and deleting all the files.

One solution to catch a flight:

Before saving go out of VNAV and LNAV by staying on PA, and save.

Delete the file .CRJFMS in Documents V4 files.

When the flight is loaded again it will be necessary to load the flight plan and delete the points already passed.

Share this post


Link to post
Share on other sites

Can you send me a whole set of these flights please (.fxml, .crj, .crjfms and .wx). That would be very helpful to track down the issue.

Share this post


Link to post
Share on other sites

Your files loaded here without any issue. However, I used the current development version (and Navigraph cycle 1811). So, I guess, this one has probably been fixed in the past few weeks.

 

image.png

Share this post


Link to post
Share on other sites

Hi Hans, So, you managed to load that YBBN YSCB file, fly for 5 minutes or so, then save the file via the Scenario tab. Close P3D, open P3D, and reload the saved flight with no issues.

 

It is one of those things. All our machines are slightly different. The majority of PC's are similar enough that their Win 10 and P3D and the Aerosoft CRJ build are within your machines allowable code range. I just need to park the CRJ and wait until the coding becomes broad enough to cope with my machine's combination. I just carried out the YBBN-YSCB flight plan and my dog harassed me for some thing at the crucial moment as I was on short final, only to lose too much airspeed and stalled when I looked back. Normally, I save my flights when in cruise and just before TOD. Obviously I could not do that in this case. 

 

Again, thanks for trying. 

Share this post


Link to post
Share on other sites

Still the same problem with v1.2.2.2.

As soon as the flight plan is filled in the file .CRJFMS it is impossible to load the flight.

By inserting a line with an "X" in front of LPT1 of the .CRJFMS file no crash but no more flight plan.

config:

FSUIPC free on P3DV4

FSUIPC with Lic P3DV3

CRJ installed only in V4

P3D V4 on a Disc different from V3

Good Courage and Thanks

 

Share this post


Link to post
Share on other sites

Marcuus, can you also attach your files here?

 

And please: I need to know which nav database (provider and cycle) was used to save the files and which one was used when loading them again.

Share this post


Link to post
Share on other sites

OK, I found the reason. Loading and saving the FMS data was the last thing that I added to the load/save process. But it seems that nobody (including me) actually tested without any FMS data entered... I fixed this and it will be available with the next update.

Share this post


Link to post
Share on other sites
9 hours ago, Hans Hartmann said:

OK, I found the reason. Loading and saving the FMS data was the last thing that I added to the load/save process. But it seems that nobody (including me) actually tested without any FMS data entered... I fixed this and it will be available with the next update.

Hans, very good that you have found an issue that may assist us with flight save/reload..

 

Can you comment about the current/previous AIRAC dates and how, if at all, they affect the save/reload flight. For example, if i save the flight with AIRAC "A" but reload with AIRAC "B"?

As long as the waypoints are the same, does the AIRAC date have any effect?

 

Did you find any difference between Nav database providers?

 

I would imagine most of flights saved would have had FMS data of some sort incorporated. In my case, as you know, the action of reload of a saved flight, would kill off my P3D session, so I am hoping the Dev version and your latest fix will solve my issue as well.

When you release the fix and hopefully, newer version, I will test the various permutations and see if I can get this matter resolved. 

Share this post


Link to post
Share on other sites
On 1.11.2018 at 01:54, por928 sagte:

Can you comment about the current/previous AIRAC dates and how, if at all, they affect the save/reload flight.

Updated SIDs/STARs usually get a new name (SID1A -> SID2A) when the navdata is updated. In this case, the procedure can't be found anymore. This would result in the loaded flightplan to be incomplete.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now