Miguel_V

Prepar3D v4.2 vers Prepar3D v4.3

Recommended Posts

My question is the following.
What is the degree of compatibility between P3D v 4.2 with the recent P3D v 4.3 with scenarios, airplanes, utilities etc... marketed by you and updated lately most to the V 4.2 which I have all installed. Will I have to wait again to update them for failures etc..., in order to install the version of P3D v 4.3, with scenarios, airplanes, utilities etc... Updated to that new version.? That is to say more time almost a year, since the 4.2 left and now wait again to update them?
Well in all puts at the time of installing that you can select the V 4.2 but in no will put v 4.3

 

Miguel

Share this post


Link to post
Share on other sites

Hi Miguel, 

I only can speak about the sceneries with the "Professional" in there Name, which are special designed for P3D V4, here we see no issues with 4.3

The dynlights seams to be less frame intensive at night, then in 4.2, that's a benefit of 4.3 and on the fix list of that update.

For other sceneries I would also not expect issues, as there are no changes effecting the BGL structures.

For aircrafts and tools it could be different and depents of the addon. A general statement could not be done here.

It is always a good idea to wait some days or weeks to see, what needs updates. To change within the first hours after such a version change will have risks, that parts of your addons are not working or block the new Sim Version to start after install of 4.3.

 

Share this post


Link to post
Share on other sites
7 minutes ago, OPabst said:

Hi Miguel, 

I only can speak about the sceneries with the "Professional" in then Name, which are special designed for P3D V4, here we see no issues with 4.3

The dynlights seams to be less frame intensive at night, then in 4.2

For other sceneries I would also not expect issues, as there are no changes effecting the BGL structures.

For aircrafts and tools it could be different and depents of the addon. A general statement could not be done here.

It is always a good idea to wait some days or weeks to see, what needs updates. To change within the first hours after such a version change will have risks, that parts of your addons are not working or block the new Sim Version to start after install of 4.2.

  

Thanks for the answer, I imagined this "do not run " to be the first. For now I have downloaded the new update, I have the professional version of Prepar3D, wait to see and continue reading in the  "forum " To see what is happening and problems that arise with the new update. To wait a year to install the new one.

  • Downvote 2

Share this post


Link to post
Share on other sites

When you wait a year, you don't need it anymore, then we have 4.4 or V5, lol.

In one or two weeks you will have a full overview, which of your addons are still critical, if there is one left.

But keep in mind, that from now on, 4.2 is outdated and new addons and fixes existing addons will be maybe only compatible to V4.3, 4.2 is out of the focus now. So don't wait tooooo long. ;)

  • Upvote 3

Share this post


Link to post
Share on other sites

Oliver makes a very good point here.... all developers will develop for P3d V4.3 now and if they choose to use the latest compilers things (certainly aircraft models) are not backwards compatible, not even with P3d V4.2. Non of our staff has P3d V4.1 installed anymore, understand what I am trying to say?

 

 

Share this post


Link to post
Share on other sites
14 hours ago, Miguel_V said:

That is to say more time almost a year, since the 4.2 left and now wait again to update them?

 

13 hours ago, Miguel_V said:

To wait a year to install the new one.

 

To be clear on this, you haven't waited a full year for v4.2 compatibility. You have waited for general v4 compatibility.

As you might remember v4.2 was only released in mid February ;) 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello, everyone,
after updating from P3Dv4.2 to 4.3 I have the following problem.

P3Dv4.3 does not start anymore.
And becomes strange when you look in Task Manager only under "Background processes" and no longer under "Apps".

more precisely, I am running P3Dv4.3 as admin, you see the startup screen and see something loading but it does NOTHING.

Do any of you also have this problem and or know what causes this problem, or even better how to fix it?

 

Thanks and greetings, Pat.

Share this post


Link to post
Share on other sites

Please open your own topic for your problem in the proper forum and don't hijack someone else's topic. 

Thank you.

  • Like 1

Share this post


Link to post
Share on other sites
vor 55 Minuten, Tom A320 sagte:

Please open your own topic for your problem in the proper forum and don't hijack someone else's topic. 

Thank you.

 

Ok SORRY !!!!

 

  • Downvote 1

Share this post


Link to post
Share on other sites
On ‎6‎/‎28‎/‎2018 at 12:38 PM, Tom A320 said:

 

 

To be clear on this, you haven't waited a full year for v4.2 compatibility. You have waited for general v4 compatibility.

As you might remember v4.2 was only released in mid February ;) 

 

 

My policy in this regard is to download everything updated to the new version either by you and others and when I have most of what I normally use, scenarios, aircraft and utilities, at that time I proceed to uninstall everything and reinstall from 0 , anyway you are right, but with what I do, I avoid I think problems touching here and there etc....
 

Share this post


Link to post
Share on other sites
On 6/28/2018 at 1:29 PM, GWI-Berlin said:

Hello, everyone,
after updating from P3Dv4.2 to 4.3 I have the following problem.

P3Dv4.3 does not start anymore.
And becomes strange when you look in Task Manager only under "Background processes" and no longer under "Apps".

more precisely, I am running P3Dv4.3 as admin, you see the startup screen and see something loading but it does NOTHING.

Do any of you also have this problem and or know what causes this problem, or even better how to fix it?

 

Thanks and greetings, Pat.

I don't really want to continue this discussion in this thread as Tom gave other directions but I'm pretty sure I had the same issue and that this is the solution http://www.prepar3d.com/forum/viewtopic.php?p=181268#p181268 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now