Sign in to follow this  
TheCameronPerson

AAR in Lightning T5

Recommended Posts

I've just popped into the T5 for the first time in a while, and try my hand at meeting up with a tanker in prep for a little jaunt over to Akrotiri - for some reason I've never properly tried an AAR in the T5.. I set myself up at 25,000ft and kept between 250-270knots and flipped on the probe light and then selected the AAR switch. I was there for a while and for some reason I wasn't seeing any increase in any of the tanks so I pressed shift-z to see my fuel percentage, I flew like that for half an hour and during that time I didn't take on any fuel. 

 

Although I've never used AAR in the T5, I usually use it in the F3 and F6 and I've never had any problems. Just to make sure all was well, I flew the F6 and F3 to check and flew the exact same parameters flying at 25,000ft between 250-270knots with the sim rate at norm and was able to fill the tanks in less than 5 minutes according to the stopwatch.. I know there was some talk about when the T5 was released that were some teething issues with the fuel transfer gauge in P3D but I'm running FSX Steam and I haven't been able to find any similar cases occurring in Steam.. If it can't be fixed then I'll just have to fly to Cyprus in the single seater but I just thought it was odd that it worked for the F3 and F6, but not the T5?

 

C.

 

2018-5-25_20-39-47-993.thumb.jpg.58b433242cb7d06fd5b6ce813afb3e66.jpg

Share this post


Link to post
Share on other sites

 Hi Cameron 

 Sounds like you have a mismatch with the fuelling LightningF3.dll.

If the F3 is working fine copy that one into the T5 folder  and make sure the entry in the panel.cfg 

also refers to " LightningF3!FuelXFR " and check in the panel / Lit_T5 folder that it has the " refuel.xml"  file.

  ……. I presume you did have a probe fitted !;)

 Cheers

 Dave

Share this post


Link to post
Share on other sites

Thanks for the reply Dave,

 

Just followed the steps and replaced T5.dll with the F3 one then changed the relevant entry in the panel.cfg and made sure I had the refuel.xml file in the Lit_T5 folder. I grabbed myself a T5 with a probe then settled down at 21,000ft at 250knots and still no fuel flow.. I only stayed for about ten minutes but the fuel state only got lower and lower.. Have I sprung a leak!?:o

 

C.

Share this post


Link to post
Share on other sites

I stayed it with for a while this time and I ran out of fuel without taking any on.. Also I tried transferring some fuel from port to starboard and again I didn't see any change in the tanks, could they be linked in some way?

 

C.

Share this post


Link to post
Share on other sites
1 hour ago, TheCameronPerson said:

I stayed it with for a while this time and I ran out of fuel without taking any on.. Also I tried transferring some fuel from port to starboard and again I didn't see any change in the tanks, could they be linked in some way?

 

C.

    Yes the .dll controls the refuelling , fuel transfer and fuel dump if applicable . If they don't work  the .dll is at fault ,no need to stay with it forever, if it is working you should see the gauges moving (slowly :0)

  Just tried mine and It works no problem.... the file is 65kb are you using the same as me ?

Share this post


Link to post
Share on other sites

Yep the T5.dll was 64.5kb as was the F3.dll.. Here's the contents of the T5 panel.cfg before I edited it to use the "LightningF3!FuelXFR" entry. As I say I've got the refuel.xml too..

 

C.

 

T5Panel.zip

Share this post


Link to post
Share on other sites
10 hours ago, TheCameronPerson said:

Yep the T5.dll was 64.5kb as was the F3.dll.. Here's the contents of the T5 panel.cfg before I edited it to use the "LightningF3!FuelXFR" entry. As I say I've got the refuel.xml too..

 

C.

 

T5Panel.zip

      Hmm ….should work then .

 try with my file...

LightningF3.dll

   Again either rename it or the panel. cfg

     failing that try changing the default aircraft.  I have had those play weird tricks with dll's

 

D

Share this post


Link to post
Share on other sites

Thanks for attaching the dll Dave I've been having a play around with it this afternoon and I'm still drawing blanks :blink: I kept it named LightningF3.dll and edited the panel.cfg. I've experimented with leaving the T5.dll in the panel folder as well as removing it but still no change and I've loaded a flight in the microlight before I loaded the T5.... Although the port/starboard transfer works just fine. I'm definitely within the parameters: T5 with probe, nav lights on, between 10,000-35,000ft, 250-300knots, probe light on and refuel switch on. On the instrument panel all the lights light up showing all the tanks but I only get a decreasing fuel state. I've gone right up to 34,500ft because I thought maybe I was burning fuel faster than taking it on but there was still no change. 

 

I'll keep running some experiments to see if I can work out a trick with the dll. Because I can refuel in F3 and the F6 and the fuel transfer works could this maybe be an issue with FSX: Steam unique to the T5? 

 

C.

Share this post


Link to post
Share on other sites

  Do you have TP and is it running ? …. if so I think for the T5 I rigged it so a tanker has to be present .

 D

Share this post


Link to post
Share on other sites

Yep TP running with a Victor called to pass on the fuel but still no fuel flow.... forgive the poor formation flying, the Victor seems to always want to descend, tired with the KC-135 but still no ball :mellow:

 

C.

2018-5-29_13-36-3-10.thumb.jpg.3e61c46148ce695fa606236dc087b51b.jpg

2018-5-29_13-36-22-981.thumb.jpg.b3e1ee11cf085b0f63162decfb9b1649.jpg

 

Share this post


Link to post
Share on other sites

 If you have wing to wing transfer working it means the .dll is ok.

    Can you try it with TP off ? ( definitely working here with TP off ), 

  There is no need to wait around seeing if it will fill  ,within a couple of seconds of selection within  the parameters you should see the gauges going up.

 D

 

      

Share this post


Link to post
Share on other sites

Just turned off TP and I've been able to successfully refuel to 100% at the same rate as I do in the F3 and F6. You were right, there seems to be some sort of conflict with Steam, TP and the DLL. I can't call up the tanker or a target but at least I can make long haul trips again! It's only when you cant refuel do you realise what short legs the Lightning had.... You've got the patience of a saint, thanks for helping me out with it :P

 

C. 

Share this post


Link to post
Share on other sites
1 hour ago, TheCameronPerson said:

Just turned off TP and I've been able to successfully refuel to 100% at the same rate as I do in the F3 and F6. You were right, there seems to be some sort of conflict with Steam, TP and the DLL. I can't call up the tanker or a target but at least I can make long haul trips again! It's only when you cant refuel do you realise what short legs the Lightning had.... You've got the patience of a saint, thanks for helping me out with it :P

 

C. 

    Have you adjusted the tankers  proximity settings to give a decent error radius ?

   Or just open the  tanker .xml (in the  panel > Lit_T5 folder,) with notepad and simply alter the 3rd element to read

<Element>
   <Select>
      <Value> 
          (L:tankerzone,bool) 1 ==
          (L:FR_switch,bool) 1 == and          
 if{ 1 (>L:RFOnXML, number)
       (L:RFOnXML, number) 1 ==        
 if{ 500 (>L:RFRateXML, number) } } 
 els{ 0 (>L:RFOnXML, number) }
     </Value>
   </Select>
</Element>

 

and save.............

 then you will be able to have the tanker but not be bound by TP's proximity settings.

 

D

 

Share this post


Link to post
Share on other sites

That entry in my tanker.xml currently looks like:

<Element>
   <Select>
      <Value> 
          (L:tanker,bool) 0 ==
          (L:tankerzone,bool) 1 == and
          (L:FR_switch,bool) 1 == and          
 if{ 1 (>L:RFOnXML, number)
       (L:RFOnXML, number) 1 ==        
 if{ 500 (>L:RFRateXML, number) } } 
 els{ 0 (>L:RFOnXML, number) }
     </Value>
   </Select>
</Element>

 

So I just delete the first line that says "(L:tanker,bool) 0 ==" to make it match yours then save it. Should I be able to run TP and call up the tanker and still refuel in the T5 if I make this edit?

 

C.

 

 

Share this post


Link to post
Share on other sites

Yes... don't forget to remove the first "and" as well as " (L:tanker,bool) 0 == "

 D

Share this post


Link to post
Share on other sites

Brilliant all working now! Took the T5 up for an AAR sortie then bumped into a visitor on the way back home... Thanks for your help and patience!

 

C.

2018-5-30_17-11-33-217.thumb.jpg.3dff2c714800efde7227e9bf537e8758.jpg

Share this post


Link to post
Share on other sites

 It looks like you loosed a missile off at him.... you trying to start a war ? :o

 D

Share this post


Link to post
Share on other sites
12 hours ago, wingman5 said:

 It looks like you loosed a missile off at him.... you trying to start a war ? :o

 D

"It came off in me hand, Chief. Honest !!"

 

Share this post


Link to post
Share on other sites

I admit it.... a missile did leave my aircraft...... Luckily for Mr Soviet the Red Top didn't fancy following the Bear and became captivated with an empty piece of airspace some miles ahead. If anyone fancies a free AA missile, it was last seen crashing towards Spithead...:blush:

Share this post


Link to post
Share on other sites
On ‎6‎/‎1‎/‎2018 at 8:36 AM, dhazelgrove said:

<fx: shock, horror>

You...……… missed ???

</fx>

 

Dave

 

 

:blush:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this