Sign in to follow this  
HKien

Update-Fenster: keine Rückmeldung

Recommended Posts

Ich nutze X-Plane 11 seit Monaten problemlos unter Linux sowie Windows 7 bzw. jetzt 10.

Aktuell habe ich mit WIndows 10 (1803) das Problem, dass ich X-Plane 11-05r2 (64 bit) nicht nach 11.20r4 hochrüsten kann.

Der Installer wird heruntergeladen, scannt erfolgreich die Dateien (1.1 GB zu installieren, 205 GB auf der SSD sind frei), bleibt aber bei "Prüfe Speicherplatz" hängen. Die Meldung lautet: X-System (Keine Rückmeldung).

Ich setze nur den WIndows-Defender ein. In der Firewall ist "x-plane-exe" zugelassen.

Was könnte die Ursache sein? Die Flugsimulation selbst lässt sich weiterhin einwandfrei ausführen.

Share this post


Link to post
Share on other sites

Hast Du mal versucht, den Installer als Administrator auszuführen (mit Rechtsklick im Kontextmenü) ?

Share this post


Link to post
Share on other sites

Vielleicht (wahrscheinlich) ist der Updater auch nicht die x-plane.exe, sondern hat einen anderen Dateinamen - so dass der Prozess vielleicht doch durch die Firewall geblockt wird? Am besten mal ausprobieren!

Viel Erfolg!

Jörg

Share this post


Link to post
Share on other sites
vor 20 Stunden , Ka8Heizer sagte:

Hast Du mal versucht, den Installer als Administrator auszuführen (mit Rechtsklick im Kontextmenü) ?

Adminrechte haben leider das Problem nicht gelöst.

Share this post


Link to post
Share on other sites
vor 20 Stunden , bavella sagte:

Vielleicht (wahrscheinlich) ist der Updater auch nicht die x-plane.exe, sondern hat einen anderen Dateinamen - so dass der Prozess vielleicht doch durch die Firewall geblockt wird? Am besten mal ausprobieren!

Viel Erfolg!

Jörg

Ich habe den Dateinamen "X-Plane 11Windows-Installer" zugelassen, was leider nichts genützt hat.

Share this post


Link to post
Share on other sites
vor 2 Stunden , Heinz Flichtbeil sagte:

Versuche vielleicht auch einmal diesen aktuellen Installer:

http://www.x-plane.com/desktop/try-it/

 

Gruß Heinz

Bisher habe ich den Installer benutzt, der beim Start von XP11 für Updates heruntergeladen wird. Allerdings läuft der Update mit dem o.g. Link genausowenig. Der Scan dauert aus mir unerfindlichen Gründen lediglich viel länger (vielleicht sucht er gründlicher?).

Soweit ich das rekonstruieren kann, hat der Update-Vorgang unter Win10 anfangs noch funktioniert. Vor ein paar Wochen habe ich 2 Dinge geändert:

1. Ich habe den gekauften Virenscanner rausgeschmissen und verlasse mich seitdem auf Defender, weil ich sonst Probleme bei Windows-Feature-Updates habe.

2. Aus dem gleichen Grund habe ich die C-Partition (mit dem X-Plane11-Verzeichnis) temporär von der SSD auf eine HD verschoben, wo sie momentan noch liegt.

Hat jemand ähnliches gemacht und dadurch Update-Probleme bekommen?

Unter Linux taucht mein Problem übrigens nicht auf.

 

Gruß Heinrich

Share this post


Link to post
Share on other sites
vor 2 Stunden , HKien sagte:

2. Aus dem gleichen Grund habe ich die C-Partition (mit dem X-Plane11-Verzeichnis) temporär von der SSD auf eine HD verschoben, wo sie momentan noch liegt.

Hat jemand ähnliches gemacht und dadurch Update-Probleme bekommen?

Da könnte der Hase im Pfeffer liegen. Die C-Partition hat zur Sicherheit nur bestimmte Zurgiffsrechte. Beim Umzug von Win 10 auf eine andere Festplatte gibt es einige Fallstricke, trotz spezieller Tools. Wenn es geht, Win neu installieren.

Ich nehme mal an, dass Dein Win 10 weiterhin auf der SSD läuft und X-Plane von der neuen HDD. Darin dürfen aber keine Reste der ursprünglichen Win-Partition sein, wenn Du (wie es sich liest) die ganze Partition rüber geschoben hast.

Zunächstmal kannst Du testweise nur die Zugriffsrecht des X-Pane-Ordners ändern. Rechtsklick, Reiter Freigabe & Sicherheit. Sollten die Kästchen beim Bearbeiten grau und gesperrt sein, sollte es bei Eigenschaften der ganzen Platte aber gehen.

So ähnlich erging es mir mal, als ich meine ZLs umkopiert hatte. Die Verknüpfungen und Ini-Eiträge waren zwar richtig, aber X-Plane zeigte nix an. Erst als ich die ZLs auf der anderen Platte auch neu installiert habe lief Alles wieder.

 

Gruss, Meik

Share this post


Link to post
Share on other sites
vor 3 Stunden , Ka8Heizer sagte:

Da könnte der Hase im Pfeffer liegen. Die C-Partition hat zur Sicherheit nur bestimmte Zurgiffsrechte. Beim Umzug von Win 10 auf eine andere Festplatte gibt es einige Fallstricke, trotz spezieller Tools. Wenn es geht, Win neu installieren.

Ich nehme mal an, dass Dein Win 10 weiterhin auf der SSD läuft und X-Plane von der neuen HDD. Darin dürfen aber keine Reste der ursprünglichen Win-Partition sein, wenn Du (wie es sich liest) die ganze Partition rüber geschoben hast.

Zunächstmal kannst Du testweise nur die Zugriffsrecht des X-Pane-Ordners ändern. Rechtsklick, Reiter Freigabe & Sicherheit. Sollten die Kästchen beim Bearbeiten grau und gesperrt sein, sollte es bei Eigenschaften der ganzen Platte aber gehen.

So ähnlich erging es mir mal, als ich meine ZLs umkopiert hatte. Die Verknüpfungen und Ini-Eiträge waren zwar richtig, aber X-Plane zeigte nix an. Erst als ich die ZLs auf der anderen Platte auch neu installiert habe lief Alles wieder.

 

Gruss, Meik

Momentan läuft alles (Win10 und XP11) noch von der Harddisk. Erst wenn 1803 stabil läuft, ziehe ich C: wieder auf die SSD um. Laut Internetmeldungen scheint 1803 sowieso noch Probleme mit diversen SSDs zu haben.

Sicherheitshalber habe ich XP11 auf der HD sogar neu installiert und probiere von dort ein Update. Deshalb müssten die Zugriffsrechte eigentlich korrekt sein. Der Updatevorgang hängt aber.

Auch wenn ich die XP11-Version auf der SSD verwende und dort ein Update versuche passiert das gleiche.

Ich frage mich, warum auch nach einer Neuinstallation keine Hochrüstung mehr möglich ist.

 

Gruß, Heinrich

 

Share this post


Link to post
Share on other sites

Noch ein Hinweis:

Im Taskmanager wird die XP11-Installations-Task als "angehalten" angezeigt, wenn der Punkt "Prüfe Speicherplatz" erreicht ist.

Was könnte hierfür die Ursache sein?

Share this post


Link to post
Share on other sites

Eigentlich deutet das mehr auf ein Rechteproblem hin. Normalerweise meldet sich der Defender, wenn ein Programm irgendwo zugreifen will. Das kann man in den Benachrichtigungseinstellungen ändern.

Im Extremfall den Defender mal übergangsweise komplett abschalten. Was auch möglich ist, das Windows die Festplatte zu früh in den Schlafmodus schickt, weil der Updater zu wenig Trafic hat.

Hier kann man in den Energieoptionen auf Dauerleistung stellen und auch die Optionen für die Komponenten einzeln einstellen.

Oder auch einfach mal ca 1 Stunde laufen lassen. Diese Speicherplatzprüfungen können auch bei anderen Tools gerade bei grossen Platten sehr lange dauern.

 

Gruss Meik

Share this post


Link to post
Share on other sites
vor 17 Stunden , Ka8Heizer sagte:

Eigentlich deutet das mehr auf ein Rechteproblem hin. Normalerweise meldet sich der Defender, wenn ein Programm irgendwo zugreifen will. Das kann man in den Benachrichtigungseinstellungen ändern.

Im Extremfall den Defender mal übergangsweise komplett abschalten. Was auch möglich ist, das Windows die Festplatte zu früh in den Schlafmodus schickt, weil der Updater zu wenig Trafic hat.

Hier kann man in den Energieoptionen auf Dauerleistung stellen und auch die Optionen für die Komponenten einzeln einstellen.

Oder auch einfach mal ca 1 Stunde laufen lassen. Diese Speicherplatzprüfungen können auch bei anderen Tools gerade bei grossen Platten sehr lange dauern.

 

Gruss Meik

Im Defender sind die Benachrichtigungseinstellungen aktiv gesetzt, auch mit deaktiviertem Defender wird der XP-Installer angehalten.

Die Energieeinstellung "Höchstleistung" bringt auch nichts, der Installer hält ja auch sofort bei "Prüfe Speicherplatz" an.

Ich hatte die Installationstask auch schon einmal über Nacht laufen lassen, was ebenfalls nichts gebracht hat.

Da meine Kenntnisse mehr im Linux-Bereich liegen, muss ich hier passen.

 

Gruss, Heinrich

Share this post


Link to post
Share on other sites

OK, meine letzten Idee wäre entweder den Updater im Kompabilitätsmodus laufen zu lassen Win 7 und 8.

Oder einen USB Boot-Stick mit WinPE oder Linux drauf und von da aus den Updater starten.

Sonst fällt mir auch erstmal nix ein.

 

Gruss, Meik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this