Recommended Posts

Despite accolades that the Hotfix resolved problems, not true for me. Cannot Add Flights, as the "Save" button is greyed out.

The last version that worked was 1.26.  Windows 10, and updated the redistributables (both 2015 and 2017 versions as suggested in the now closed forum threat).

And done the  fix for  .Net suggestion.  Formerly functioning PFPX and TOPCAT programs have  not worked since the 1.28/1.28.9i updates.  Ideas please.  DJ

Share this post


Link to post
Share on other sites

Post a snapshot of your installed vcredist files from 'Programs & Features' to include the installed versions.

 

Also snapshot the 'flight' entry you are trying to save.

Share this post


Link to post
Share on other sites

Thankyou for reply.  Hopefully the image shows "Save" button top left corner is greyed out; "Close" without save is normal. Cannot get past this screen.

VC Redistributables - there is a long list of past installations, only last 2 are shown in snapshot. That not an issue in the past.

I have tried reinstalling  PFPX 1.28 and 1.28.9i program between laptop (Win10) and desktop (Win7) - identical problem.

1.26 worked fine on either machine - anywhere I can get the older version back?? Thanks, DJ

Add Flight window_Save button greyed out.jpg

VC Redist snapshot.jpg

Share this post


Link to post
Share on other sites

Thanks Christian.

 

New screenshot - no red boxes, AND NOT EVEN the "Close" button top right corner this time - another change!

Being so frustrated with loosing what was a working program (Ver 1.26) until the 1.28 updates/hotfixes - I have gone around the house uninstalling/reinstalling on 3 different computers  (Win7 and Win10) to see if something local/hardware causing this. All have same problem. Left TOPCAT alone as it seems unlikley culprit. 

Q: Have seen "Installed on 3 machines" and "Running on ... computers" (or similar) messages - could anything to do with that be inhibiting?

 

Can I get from any archive Ver 1.26, which worked fine for me? I have studied changelogs but cannot spot anything suggestive of this problem.

Thanks for help - its amazing - we are on opposite sides of the world and still help comes! David.

 

5a0b6344492f9_PFPXAddFlightWindowScreenshot.thumb.jpg.be527dc74e789cd7de8c336d7dcbed12.jpg

Share this post


Link to post
Share on other sites
2 minutes ago, djones1149 said:

Can I get from any archive Ver 1.26, which worked fine for me?

 

Just read my previous answer to that question ;) 

Share this post


Link to post
Share on other sites

Sorry Tom - I thought you were referring to Ver1.28 or the Hotfix Ver1.28.9i (both of which show during opening them). 

Possibly you were asking for the Version from the properties menu ... in the attached ...16.0.0.435?   Thanks, david.

AS_PFPX_V128 Properties.jpg

Share this post


Link to post
Share on other sites

The problems you are facing have always been linked to problems with the VC++ redist packages.

 

What I have noticed is, that you are not on the latest version of the 2015 package. You are on 14.0.24212 while I have 14.0.24215 installed and don't face any such problems.

 

Capture.PNG

 

 

Share this post


Link to post
Share on other sites
1 minute ago, djones1149 said:

Sorry Tom - I thought you were referring to Ver1.28 or the Hotfix Ver1.28.9i (both of which show during opening them). 

Possibly you were asking for the Version from the properties menu ... in the attached ...16.0.0.435?   Thanks, david.

 

No. You were asking for a chance to get an older version of PFPX for download, and I tried you point you on a little trick to use the official download server of FlightSimSoft to get it from there. 

On their website they only list the latest version, but the older versions are still available on the server. You just need to modify the version number within the link a little bit ;) 

 

Share this post


Link to post
Share on other sites

Thanks - understood now.

BUT ... Judith has sent me a dropbox download link for Ver1.26... which also shows exactly the same problem! And other crashes.

 

She suggests my system must have a problem, BUT - that sounds illogical - I have 3 computers - "Old"desktop (Win7) and Laptop (Win10) on which it ran fine.

A new PC Build (higher spec hardware but refused Win10 - ie Win7 again) is in the process of transfering/reinstalling programs etc. Old PC still used till new one fully established. The exact same problems occur if PFPX is uninstalled then reinstalled on any one of the 3, including the 1.26 version just sent.  I tried installing on a different HDD in same PC ... no change.   That can't be "my system" because 2 of them with no hardware or software changes were proven  to work in past. 

I asked Judith about multiple installations/activations - in case that was inhibiting the program ... no answer but intend to reset my activation count.

Stumped ...!  But still gratefu,l for your help.  DJ

Share this post


Link to post
Share on other sites

TOM: thanks, updating ...

1. Your suggestion for getting an older version worked fine (better than Judith's dropbox link - as they came up with different .exe files)

2. Using that earlier Ver 1.26, updated by AS_PFPX_UPD_V128.exe, I regained ability to Add Flight and save it (ie the "Save" button reappeared top left corner)

3. ... only to have PFPX crash/close down further on during planning. [I haven't examined EventLogs yet - not too familiar with what to look for in them].

4. Going beyond there with Hotfixes ( .9c or .9i) loses the buttons again - varies between NO Save/Close buttons at all OR Close button active but Save button greyed out.

5. vcred 2015 versions: tried your suggestion to get later versions, but none found from MS website (14.0.24123 in Win7 and 14.0.21212 in Win10 are the highest versions between my laptop and Desktop PC. 

Q: Is it possible they are region specific - like different for Europe, other languages etc?

 

In summary: variable results with some functions regained, but crashing later anyway, hotfixes not solving, and different vcred 2015 versions to yours.

                     2 steps forward, one back.

Cheers, david

Share this post


Link to post
Share on other sites
2 hours ago, djones1149 said:

Your suggestion for getting an older version worked fine (better than Judith's dropbox link - as they came up with different .exe files)

 

I guess the version you got from Judith included the latest 1.26 hotfixes. The version from the website is always the initial release version, without any hotfixes.

 

2 hours ago, djones1149 said:

Q: Is it possible they are region specific - like different for Europe, other languages etc?

 

I don't think so, and I don't find any hint on that on the MS websites. I always download the English packages although the base installation of my Windows was German.

 

So this link must have given me my version:

I don't have the 2017 package installed yet, as the 2015 version I have installed haven't given me any problems yet.

 

Share this post


Link to post
Share on other sites

Hello Tom,

 

The linked file is version 14.0.24212 which is was the known working SP3 version we have been recommending, and indeed is still functioning here on WIN7 & WIN10 64bit

 

DJ

 

As you have installed the 2017 x64 vcredist try also installing the x86 version available at the foot of this page

The 2017 version will replace the 2015 entry, again this is tested as working here on WIN10 64bit

  • Upvote 1

Share this post


Link to post
Share on other sites
1 minute ago, srcooke said:

The linked file is version 14.0.24212 which is was the known working SP3 version we have been recommending, and indeed is still functioning here on WIN7 & WIN10 64bit

 

I haven't installed my "14.0.24215" version manually, so some lately installed other software must have done it under the hood.

 

Anyway, it can be downloaded from Microsoft directly, while the original SP3 link still gives the 14.0.24212 version:

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks Tom - with your links I found the 24215 versions of the VC++redist - where  ...212 was the highest I could get from "official" MS website and MS updates.

I note others say  ...212 was the working version - thnaks for that info Stephen.

With your help I reinstalled PFPX Ver 1.26 which is stable again --

I will leave it alone for a while as it is working and I hv a task to achieve with it - then try the newer versions again with the new redistributables.

I have not heard yet whether activation count could be working against me also (Judith).

Mystery remains ....   DJ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now