Vortac12

FSX Crash when inserting radial fix

Recommended Posts

I want to insert a fix and a radial.  I can load a fix but when I put a radial into the FMS, FSX immediately crashes.  This happens every time I insert the radial.  I currently have version 1.3 installed and am running on Win 7 with FSX acceleration.

Share this post


Link to post
Share on other sites
2 hours ago, Max Reverse said:

Blahhh,

this feature works perfect. You can use up to 4 Fix inputs, with radial and distancering.

 

No, this feature works sometimes only.
Try to add a circle fix of 5 nm around AC (110.3, near LFKJ) for example.
When you put the radius value in 4L key nothing happens ; the value disappears.
And it's the same for hundred waypoints
Only radials work in this case, but sometimes is only radius.

(PS: sorry for my poor english xD)

2015-11-6_12-47-49-167.png

Share this post


Link to post
Share on other sites

Edit: In this case (AC, 100.30), radials do not work too. I can add a 203 radial, but not 23...

Share this post


Link to post
Share on other sites

I cannot insert certain radials into the fix page when I was trying to do an approach into YAYE. I put 135 into the radial box and nothing happens. I put in 35 it works just fine. any idea why?

Share this post


Link to post
Share on other sites
1 hour ago, Max Reverse said:

I never had problems with the Fix, and I use it very often. You are using the latest release of the Airbus?

Yep, 1.31, Steam Edition approaching YAYE can't add the 135 radial to YAYE.

Share this post


Link to post
Share on other sites

I think it is a known bug, I already read a post about that but cannot find it again.
Anyway, this is not very important, we can fly without fix help.

 

Share this post


Link to post
Share on other sites

I am able to reproduce the problem.  I wanted to do a practice circuit at London during the fog so I did not program a flight plan.  I put EGLL as the departure and arrival, then went into the fix pages and tried to set up the runway centerline extension so I did not have to program a route.  When I clicked on fix, I entered the ILS and when I entered the radial it crashed.  If I put a flight plan it will work.  I never had it where it did nothing. It either caused a crash to desktop or it worked.

Share this post


Link to post
Share on other sites
1 hour ago, Vortac12 said:

I am able to reproduce the problem.  I wanted to do a practice circuit at London during the fog so I did not program a flight plan.  I put EGLL as the departure and arrival, then went into the fix pages and tried to set up the runway centerline extension so I did not have to program a route.  When I clicked on fix, I entered the ILS and when I entered the radial it crashed.  If I put a flight plan it will work.  I never had it where it did nothing. It either caused a crash to desktop or it worked.

Sorry to have hijacked your post, I've only met your problem one time.
I think Tom's answer was the correct way for me. Did you try it?

Share this post


Link to post
Share on other sites

yea, I did and right after I did it, it worked so I thought it was correct.  Then another day I tried to do another circuit and it crashed again.  It appears that you have to have a flight plan in the FMS, not just a departure and destination airport.  You did say in one of your posts that it is a feature not really needed and you are correct if you have a flight plan inserted.  SIDS STARS, APPROACH and ILS will bring you right in.  But sometimes I just like to do a few touch and goes and don't want to program a whole flight. 

Share this post


Link to post
Share on other sites
On ‎10‎/‎11‎/‎2015‎ ‎02‎:‎06‎:‎10, Vortac12 said:

yea, I did and right after I did it, it worked so I thought it was correct.  Then another day I tried to do another circuit and it crashed again.  It appears that you have to have a flight plan in the FMS, not just a departure and destination airport.  You did say in one of your posts that it is a feature not really needed and you are correct if you have a flight plan inserted.  SIDS STARS, APPROACH and ILS will bring you right in.  But sometimes I just like to do a few touch and goes and don't want to program a whole flight. 

What I do is that I put in the departure/arrival airport (which would probably be the same if you just want to do touch and goes) and also put in the ILS approach in the MCDU for NAV for the active runway. Makes your life so much easier, especially if you want a go around track.

Share this post


Link to post
Share on other sites
8 hours ago, bill0014 said:

What I do is that I put in the departure/arrival airport (which would probably be the same if you just want to do touch and goes) and also put in the ILS approach in the MCDU for NAV for the active runway. Makes your life so much easier, especially if you want a go around track.

Fixes are useful for some VPT approaches. Also can be helpful in order to follow a DME arc by hand or any other visual approaches (whom are not in your FMS). 
 

Share this post


Link to post
Share on other sites

I am experiencing the same issue. As suggested by Dave I updated the  VC++ Redistributables before trying again. I entered EDCP radial 310 then FSX Steam Edition CTD. Any ideas? I use these as a PVOR as I do in real life flying for a centre line reference for airports with no instrument approaches. I have experienced crash to desktop multiple times now. I tried entering just 31 for the radial, immediately I CTD. 

Share this post


Link to post
Share on other sites

Well, me too. I used the feature for the first time since 1.21 (a month ago) now on 1.31. Also, this was for non instrument approach.

 

fmgs.dll_crash.jpg

Share this post


Link to post
Share on other sites

Hi, is it possible to add all necessary VC++ Redistributables and others files to A3xx installator? Regards.


 

Share this post


Link to post
Share on other sites

That surely would be a possibility, but in my it's better to get the latest versions from the Microsoft webpage yourself.

Let's assume (and this is an assumption, nothing else!) the next installer for the buses (SP4, 1.40) will come with all the files. Some time next years you decide to uninstall the bus and a year later you install it again. Then chances are high that you install outdated versions, which could cause any kind of strange phenomena on your machine. 

But before continue to discuss this, I would like to stay on topic, and ask again if any of the users who posted in here have updated all the files as suggested and is still facing this problem?

Share this post


Link to post
Share on other sites
15 hours ago, Tom A320 said:

Can you please confirm that you did what I suggested in #2 of this topic?

Hi Tom

I had all of them (32-bit and 64-bit) except 2015's - after installing them and reboot, no more crash.

I would suggest that this requirement changes be listed with release notes on the page with "Update News and Hotfixes" Installing 1.31 and perhaps "InFSX" manual, system requirements section or adding a software requirement section.

With that kind of change requirements If I don't know that is needed then I don't install. Giving us heads up I think most of us would catch this and would not have to bother you with CTD. Unless it's listed elsewhere that I don't know about it.

On another note, now that there is no CTD, I concur the similar experience few other users had, inserting a value nothing happens.

In my case LDSP, entering radial 230 stayed blank, then tried 50 was ok, then tried another way point on route with 230 was ok, then back for LDSP - yey, it worked.

Ok, so it worked but not as expected. That's ok for me if few extra clicks is all I need.

 

Thanks,

Michael

 

 

 

 

Share this post


Link to post
Share on other sites
Quote

In my case LDSP, entering radial 230 stayed blank, then tried 50 was ok, then tried another way point on route with 230 was ok, then back for LDSP - yey, it worked.

Useful tip, i'll try it :)

Share this post


Link to post
Share on other sites

Hi,

One year after, this topic hadn't been closed ;-)

Back from xplane to p3d for the crj release (so impatient), just installed again this aircraft (the new 1.31 version), play again with it (amazing bird anyway), try a flight from LGSM, URNIL departure, and need some visual help to fly by hand this procedure :

- R 266 deg from SAM (Samos VOR/DME 111.6) : OK

- R 173 deg from SAM : KO, nothing happens.

So do you plane to fix this issue or not?

Cheers,

(sorry again for my poor english :p)

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.