larshall

member
  • Content count

    4
  • Joined

  • Last visited

Everything posted by larshall

  1. For me (coming from 8 GB RAM) - because the min. and recommended RAM requirements look a little high.
  2. larshall

    Twotter now Prepar3D v4 compatible

    Still not up to 1.21 at FSS
  3. larshall

    Annual poll on platform

    For now P3D3 + FSX:SE. Will probably add Dovetail FS when available